Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1052404 - Upgrading atop from version 1.26-3.el5 to version 1.27-1.el5 causes atop to fail on start
Summary: Upgrading atop from version 1.26-3.el5 to version 1.27-1.el5 causes atop to f...
Keywords:
Status: CLOSED DUPLICATE of bug 1024759
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: atop
Version: el5
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 19:00 UTC by Michael Durket
Modified: 2014-01-16 14:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-16 14:46:34 UTC
Type: Bug


Attachments (Terms of Use)

Description Michael Durket 2014-01-13 19:00:14 UTC
Description of problem: When upgrading Redhat Enterprise 5.9 to Redhat Enterprise 5.10 a new version of atop (1.27-1.el5) updates the prior version (1.26-3.el5). However, starting the new version of atop always fails with a message in the file /var/log/atop/atop.log that says:

existing file /var/log/atop/atop_20140113 has incompatible header
(created by version 1.26 - current version 1.27)



Version-Release number of selected component (if applicable): 1.27-1.el5


How reproducible: Completely - fails every time on an upgrade of a system from Redhat 5.9 to Redhat 5.10


Steps to Reproduce:
1. Do a yum upgrade on any Redhat 5.x system with atop version 1.26 installed
2.
3.

Actual results:
# /sbin/service atop start
Starting atop:                                                     [FAILED]



Expected results:
# /sbin/service atop start
Starting atop:                                                     [OK]


Additional info: A workaround (which is unsatisfactory) is to delete the entire contents of /var/log/atop (or move it somewhere else), remove the new version of atop and reinstall it. atop will then work correctly, but you won't be able to read any of the prior atop raw logs since atop will complain that the format is wrong.

Comment 1 Gwyn Ciesla 2014-01-16 14:46:34 UTC

*** This bug has been marked as a duplicate of bug 1024759 ***


Note You need to log in before you can comment on or make changes to this bug.