Bug 1052423 - missing BuildRequires: libgcrypt-devel on grilo-plugins-0.2.6-1.el7.src.rpm
Summary: missing BuildRequires: libgcrypt-devel on grilo-plugins-0.2.6-1.el7.src.rpm
Keywords:
Status: CLOSED DUPLICATE of bug 1048862
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: grilo-plugins
Version: 7.0
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bastien Nocera
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-13 19:40 UTC by Pat Riehecky
Modified: 2014-01-14 10:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-14 10:50:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
mock config for replication (1.29 KB, text/plain)
2014-01-13 19:40 UTC, Pat Riehecky
no flags Details

Description Pat Riehecky 2014-01-13 19:40:05 UTC
Created attachment 849574 [details]
mock config for replication

Description of problem: grilo-plugins-0.2.6-1.el7 cannot be rebuilt with the specified BuildRequires.


Version-Release number of selected component (if applicable):grilo-plugins-0.2.6-1.el7.src.rpm


How reproducible: 100%


Steps to Reproduce:
1.install minimal build environment with listed BuildRequires:
2.rpmbuild --rebuild grilo-plugins-0.2.6-1.el7.src.rpm
3.

Actual results:
<snip>
+ autoreconf -i -f
configure.ac:152: warning: macro 'AM_PATH_LIBGCRYPT' not found in library
libtoolize: putting auxiliary files in `.'.
libtoolize: copying file `./ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `m4'.
libtoolize: copying file `m4/libtool.m4'
libtoolize: copying file `m4/ltoptions.m4'
libtoolize: copying file `m4/ltsugar.m4'
libtoolize: copying file `m4/ltversion.m4'
libtoolize: copying file `m4/lt~obsolete.m4'
configure.ac:152: warning: macro 'AM_PATH_LIBGCRYPT' not found in library
configure.ac:152: error: possibly undefined macro: AM_PATH_LIBGCRYPT
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1
error: Bad exit status from /var/tmp/rpm-tmp.f2ZpPO (%prep)
    Bad exit status from /var/tmp/rpm-tmp.f2ZpPO (%prep)
RPM build errors:
Child return code was: 1
</snip>

Expected results:
Correct BuildRequires: within the package

Additional info:
AM_PATH_LIBGCRYPT is provided by libgcrypt-devel

Comment 2 Bastien Nocera 2014-01-14 10:50:23 UTC

*** This bug has been marked as a duplicate of bug 1048862 ***


Note You need to log in before you can comment on or make changes to this bug.