Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1052842 - ipa-server-install fail if both mod_nss and mod_ssl are installed
Summary: ipa-server-install fail if both mod_nss and mod_ssl are installed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Martin Kosek
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-14 07:56 UTC by David Spurek
Modified: 2015-03-02 05:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-15 09:37:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description David Spurek 2014-01-14 07:56:12 UTC
Description of problem:
ipa-server-install fail if both mod_nss and mod_ssl are installed.

The log file for this installation can be found in /var/log/ipaserver-install.log
==============================================================================
This program will set up the IPA Server.

This includes:
  * Configure a stand-alone CA (dogtag) for certificate management
  * Configure the Network Time Daemon (ntpd)
  * Create and configure an instance of Directory Server
  * Create and configure a Kerberos Key Distribution Center (KDC)
  * Configure Apache (httpd)

To accept the default shown in brackets, press the Enter key.

Apache is already configured with a listener on port 443:
_default_:443          pes-guest-67.lab.eng.brq.redhat.com (/etc/httpd/conf.d/ssl.conf:74)
IPA requires that mod_nss be used for port 443.
Aborting installation
:: [   FAIL   ] :: Running 'ipa-server-install --hostname=pes-guest-67.lab.eng.brq.redhat.com -r TESTREALM -n lab.eng.brq.redhat.com -p Secret123 -P Secret123 -a Secret123 --unattended'

Version-Release number of selected component (if applicable):
mod_nss-1.0.8-19.el6_5.x86_64
mod_ssl-2.2.15-29.el6_4.x86_64
ipa-server-3.0.0-37.el6.x86_64


How reproducible:
always

Steps to Reproduce:
1.install mod_ssl and mod_nss
2.run ipa-server-install
3.

Actual results:
fail during ipa-server-install

Expected results:
ipa-server-install pass

Additional info:

part of /var/log/ipaserver-install.log:
...
2014-01-14T06:44:26Z DEBUG args=/usr/sbin/httpd -t -D DUMP_VHOSTS
2014-01-14T06:44:26Z DEBUG stdout=VirtualHost configuration:
wildcard NameVirtualHosts and _default_ servers:
_default_:8443         pes-guest-67.lab.eng.brq.redhat.com (/etc/httpd/conf.d/nss.conf:84)
_default_:443          pes-guest-67.lab.eng.brq.redhat.com (/etc/httpd/conf.d/ssl.conf:74)

2014-01-14T06:44:26Z DEBUG stderr=Syntax OK

2014-01-14T06:44:26Z INFO   File "/usr/lib/python2.6/site-packages/ipaserver/install/installutils.py", line 614, in run_script
    return_value = main_function()

  File "/usr/sbin/ipa-server-install", line 735, in main
    sys.exit("Aborting installation")

2014-01-14T06:44:26Z INFO The ipa-server-install command failed, exception: SystemExit: Aborting installation

Comment 1 Martin Kosek 2014-01-14 08:15:43 UTC
IPA is expected to fail in this case. The issue is clearly described in the error message:

# ipa-server-install
...
IPA requires that mod_nss be used for port 443.
Aborting installation

Port 443 is owned by mod_ssl, IPA installer cannot just change it's port to different (which one?) or uninstall mod_ssl it without user interaction. So the error message and the failure is right.

Change mod_ssl to use another port and ipa-server-install should pass.

I plan to close as NOTABUG if other issue does not appear.

Comment 2 Martin Kosek 2014-01-15 09:37:34 UTC
Closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.