Bug 1052940 - Regression in sudo 1.8.6p3-7 package, double quotes are not accepted in sudoers
Summary: Regression in sudo 1.8.6p3-7 package, double quotes are not accepted in sudoers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sudo
Version: 6.5
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: rc
: ---
Assignee: Daniel Kopeček
QA Contact: David Spurek
URL:
Whiteboard:
Depends On:
Blocks: 1070830 1092499
TreeView+ depends on / blocked
 
Reported: 2014-01-14 13:12 UTC by Savitoj Singh
Modified: 2018-12-09 17:28 UTC (History)
4 users (show)

Fixed In Version: sudo-1.8.6p3-13.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1092499 (view as bug list)
Environment:
Last Closed: 2014-10-14 06:45:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
proposed patch (1.10 KB, patch)
2014-05-21 10:48 UTC, Daniel Kopeček
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1484 0 normal SHIPPED_LIVE sudo bug fix update 2014-10-14 01:28:34 UTC

Description Savitoj Singh 2014-01-14 13:12:15 UTC
Description of problem:
We have a system integrated with AD and applying local sudoers rule on group basis, "%domain users" ALL=(ALL)       ALL

Requirements is to change the passprompt of the sudo, like [sudo] password for user: message TO [test] password for IDM\user:

Version-Release number of selected component (if applicable):
sudo-1.8.6p3-12.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Integrate linux machine with AD, and allow any group containing escape character, in my case "domain users"

2. Add line to sudoers file "%domain users" ALL=(ALL)       ALL to run all commands etc.

3. Add the line to change the passprompt of sudo

Defaults:"%domain users" passprompt="[test] password for IDM\%u:"

4. Run command using member of that group using sudo

Actual results:

Not working, Showing default prompt

Expected results:

[test] password for IDM\savitoj:

Additional info:

1. If I make changes in sudoers file using escape character, it works like charm in sudo-1.8.6p3-12.el6.x86_64 version.

Defaults: %domain\ users passprompt="[abc] password for IDM\%u:"


2. If I downgrade the package of sudo to sudo-1.7.4p5-13.el6_3.x86_64

and in sudoers, Defaults:"%domain users" passprompt="[test] password for IDM\%u:"


Works like charm

Seems that there is a regression in package of Sudo-1.8.6p3-12.el6.x86_64


- Savitoj

IRC- savitoj

Comment 3 Savitoj Singh 2014-01-22 10:42:14 UTC
Hi,

Any update on this bug ?


- Savitoj

Comment 6 Daniel Kopeček 2014-05-21 10:48:59 UTC
Created attachment 897901 [details]
proposed patch

Comment 10 errata-xmlrpc 2014-10-14 06:45:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1484.html


Note You need to log in before you can comment on or make changes to this bug.