Bug 1052974 - Missing buildrequires
Summary: Missing buildrequires
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: perl-XML-DOM
Version: 7.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: perl-maint-list
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
: 1055738 1055770 (view as bug list)
Depends On:
Blocks: 1023810 1055770
TreeView+ depends on / blocked
 
Reported: 2014-01-14 14:26 UTC by Zenon Panoussis
Modified: 2014-06-18 08:29 UTC (History)
5 users (show)

Fixed In Version: perl-XML-DOM-1.44-19.el7
Doc Type: Bug Fix
Doc Text:
Cause: Rebuilding perl-XML-DOM without installed perl-libwww-perl package. Consequence: The build process fails on running tests due to missing LWP::UserAgent Perl module. Fix: All build-time dependencies have been specified in the specification file for perl-XML-DOM package. Result: The perl-XML-DOM package can be rebuild in a minimal environment.
Clone Of:
Environment:
Last Closed: 2014-06-12 08:30:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
build.log (18.18 KB, text/plain)
2014-01-14 14:26 UTC, Zenon Panoussis
no flags Details
Fix (2.20 KB, patch)
2014-01-14 14:53 UTC, Petr Pisar
no flags Details | Diff

Description Zenon Panoussis 2014-01-14 14:26:46 UTC
Created attachment 849960 [details]
build.log

The tests use LWP/UserAgent.pm. rpm doesn't know about this, so building in mock fails the tests. Log attached.

Comment 2 Zenon Panoussis 2014-01-14 14:40:36 UTC
Tested with "Buildrequires:  perl(LWP::UserAgent)" and then it built OK.

Comment 3 Petr Pisar 2014-01-14 14:53:02 UTC
Created attachment 849988 [details]
Fix

Comment 6 Petr Pisar 2014-01-21 07:07:10 UTC
*** Bug 1055738 has been marked as a duplicate of this bug. ***

Comment 8 John Feeney 2014-06-11 19:54:40 UTC
*** Bug 1055770 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.