Bug 1053 - Get 'no rule' on make config
Get 'no rule' on make config
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: make (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-05 15:54 EST by steve.mckoy
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-08 13:12:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description steve.mckoy 1999-02-05 15:54:12 EST
Trying to build a new Kernel with a make config and getting
the message 'no rule default'.  I am trying to add CDROM
support for a SCSI Adaptec 2940 drive.  I can't issue mount
/mnt/cdrom because it gets iso9660 unsupported filetype.
Does LINUX stand for 'Lock-up In Unix'?
Comment 1 Aleksey Nogin 1999-02-07 20:21:59 EST
Make sure you have both kernel-source and kernel-headers RPMs
installed. Make sure you are in the /usr/src/linux directory when
calling make.

AFAIK, the kernel RPM included in RedHat 5.2 includes isofs support,
so your getting "unsupported filesystem type" error message may
indicate that you are doing something wrong.
Comment 2 steve.mckoy 1999-02-16 17:13:59 EST
Thanks for responding to my little problem so quickly.  You were
right - I had not installed everything.  So, I went back and booted
up the CD and did an 'UPGRADE' and added everything I could find
relating to the kernel and make and scsi.  After that I was able to
do the MAKE.  However, after two long drawn out attempts to build the
kernel, I still don't have support for ISO9660 and my SCSI CD.  The
CD drive is a Toshiba xm3401b which I don't see in the supported CD
list.  I just can't believe that this LINUX system requires this much
labor intensive tailoring to recognize my basic hardware when the
install CD does it just fine.  Also, I tried the three 'MAKE CONFIG',
'MAKE MENUCONFIG', and 'MAKE XCONFIG'.  The first two worked and the
'MAKE MENUCONFIG' is the one that I had to use, but the 'MAKE
XCONFIG' gets the message:  'Error in startup script:  invalid
command name "button" '.  It also says line 26 of script kconfig.tk
which shows "button .ref".  Since I am just now trying to learn UNIX,
I don't know how to fix this script.  Anyway, as I said, I got the
menuconfig to work and tried to specify all the necessary support to
include the ADAPTEC 2940 controller, SCSI CD support, and ISO9660
filesystem support.  I then followed the book doing all the MAKEs to
create a zImage and copy it into /boot.  But I still get the same
message as if nothing has changed.  I issue the command: 'mount
/mnt/cdrom' and it says ISO9660 is not supported in the kernel.
I read through the HOWTO on kernels, CDROMs, and SCSIs.
My question is - Do you have any idea what may be wrong with what I
am doing?  Why doesn't this install process build a suggested kernel
build configuration and modify ALL necessary peripheral files like
/etc/fstab that includes ALL hardware recognized by the install
process?  If I can't get my Toshiba xm3401b CD to work under the
Adaptec 2940, I won't be able to use Linux very well.
Comment 3 David Lawrence 1999-04-08 13:12:59 EDT
Did you remember to update /etc/lilo.conf and run the 'lilo' command
after copying the zImage to /boot? After compiling the kernel using

make dep; make clean; make zImage

you need to run

make modules; make modules_install

The copy the new kernel from ./arch/i386/boot/zImage to
/boot/vmlinuz-<some number>. The edit /etc/lilo.conf to change the
image= line to point to the new file you placed in /boot. The run

lilo -v

This will update your master boot record to point to the new kernel.
Otherwise it will still load the old kernel.

If this still does not help you, please contact tech support at
http://www.redhat.com/support and they should be able to help you out.

Note You need to log in before you can comment on or make changes to this bug.