Bug 1053037 - Unified release RPM for Fedora and EL6
Summary: Unified release RPM for Fedora and EL6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Meni Yakove
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-14 15:41 UTC by Dave Neary
Modified: 2014-03-31 12:23 UTC (History)
7 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Enhancement
Doc Text:
Feature: Unified release RPM for Fedora and EL6 Reason: Result (if any):
Clone Of:
Environment:
Last Closed: 2014-03-31 12:23:08 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 23661 0 None None None Never

Description Dave Neary 2014-01-14 15:41:50 UTC
RDO has one release RPM file which enables the correct repo (Fedora or EL6) at install time (see http://openstack.redhat.com/Quickstart).

It would be great if we could have something similar for oVirt, unifying Fedora and EL6, and removing a question that the user has to ask himself when installing.

I would also like to have one URL which is always the current stable release, and one which is the current latest devel release, which will be sym links which will be updated on release.

Is that easy/possible?

Comment 1 Sandro Bonazzola 2014-01-15 08:20:47 UTC
(In reply to Dave Neary from comment #0)
> Is that easy/possible?

It's not so easy but possible.

Comment 2 Pavel Stehlik 2014-03-11 07:00:30 UTC
RPM location 
 http://resources.ovirt.org/releases/ovirt-release.noarch.rpm

/etc/yum.repos.d/ovirt.repo  is generated at %post install during rpm setup based on rpm %dist value

Comment 3 Sandro Bonazzola 2014-03-31 12:23:08 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.