Bug 1053071 - virsh cpu-stats strange output
Summary: virsh cpu-stats strange output
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Kletzander
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-14 16:20 UTC by Andrew Jones
Modified: 2014-01-16 07:42 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-16 07:42:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Andrew Jones 2014-01-14 16:20:58 UTC
host:   kernel-3.10.0-54.0.1.el7.x86_64
        qemu-kvm-rhev-1.5.3-35.el7.x86_64
        libvirt-1.1.1-18.el7.x86_64
guest:  kernel-3.10.0-54.0.1.el7.x86_64

Host has 160 cpus

When running 'virsh cpu-stats' cpu 140 output

CPU140:
        cpu_time             0.000000000 seconds
	vcpu_time            0.000000000 seconds
	cpu_time            27.394963770 seconds
	vcpu_time           27.394658147 seconds

The first two outputs are what's strange. This reproduced three times, always for cpu140, but, sigh, now I can't reproduce it...

Comment 3 Martin Kletzander 2014-01-16 07:42:30 UTC
Unfortunately we weren't able to either reproduce that or find any possibility for it to happen through code inspection (unless somebody is rewriting our memory, of course).  I have to close this for now as there are insufficient data for us to continue.  At least we have a bug to track that it already happened and if this happens again this may be reopened and we are more likely to know where to begin.

Don't hesitate to reopen this bug in case it is reproducible again.


Note You need to log in before you can comment on or make changes to this bug.