Bug 1053209 - swig support for octave 3.8
Summary: swig support for octave 3.8
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: swig
Version: rawhide
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1047053
TreeView+ depends on / blocked
 
Reported: 2014-01-14 20:57 UTC by Orion Poplawski
Modified: 2014-03-02 03:29 UTC (History)
3 users (show)

Fixed In Version: swig-2.0.12-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-02 03:29:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Orion Poplawski 2014-01-14 20:57:19 UTC
Description of problem:

octave 3.8 has introduced some incompatibilities for swig.  This was addressed upstream:

https://sourceforge.net/p/swig/bugs/1353/
https://github.com/swig/swig/commit/5b167cc12daf9ea275c17fedaefc975450613ab2

This patch applies cleanly (minus the changes to CHANGES.current) to 2.0.11.  

I would really like this in rawhide so I can try to re-enable octave support for plplot.  We could either apply this patch or start tracking the 3.0.0 upstream development.  Preferences?

Version-Release number of selected component (if applicable):
2.0.11-2

Comment 1 Dmitrij S. Kryzhevich 2014-02-21 04:39:47 UTC
I'm interested in supporting new octave too.

Comment 2 Björn 'besser82' Esser 2014-02-25 13:42:58 UTC
The SWIG-developers just released 3.0.0 beta1 [1] about a week ago, which offers support for Octave 3.8.0+.  I'd really vote +1 to rebase rawhide-branch to this.

[1] https://github.com/swig/swig/releases/tag/rel-3.0.0-beta1

Comment 3 Orion Poplawski 2014-03-02 03:29:13 UTC
This is fixed now in swig-2.0.12-1.fc21.


Note You need to log in before you can comment on or make changes to this bug.