Bug 1053266 - (CVE-2013-5896) CVE-2013-5896 OpenJDK: com.sun.corba.se. should be restricted package (CORBA, 8025022)
CVE-2013-5896 OpenJDK: com.sun.corba.se. should be restricted package (CORBA,...
Status: CLOSED ERRATA
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20140114,repor...
: Security
Depends On:
Blocks: 1049945
  Show dependency treegraph
 
Reported: 2014-01-14 17:06 EST by Tomas Hoger
Modified: 2015-07-15 21:23 EDT (History)
5 users (show)

See Also:
Fixed In Version: icedtea 2.4.4, icedtea 2.3.13, icedtea 1.12.8, icedtea 1.13.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:41:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Hoger 2014-01-14 17:06:00 EST
The default Java security properties configuration did not restrict access to sub-packages of the com.sun.corba.se package. An untrusted Java application or applet could use this flaw to trigger denial of service. This update lists whole com.sun.corba.se package as restricted in the java.security file.
Comment 1 Tomas Hoger 2014-01-14 17:07:53 EST
Public now via Oracle CPU January 2014.  Fixed in Oracle JDK 7u51, 6u71 and 5.0u61.

External References:

http://www.oracle.com/technetwork/topics/security/cpujan2014-1972949.html
Comment 2 Tomas Hoger 2014-01-14 17:09:44 EST
Related note in the release notes:

http://www.oracle.com/technetwork/java/javase/7u51-relnotes-2085002.html

  Area:otherlibs/corba
  Synopsis:com.sun.corba.se.** should be on restricted package list.

  The JDK internal package com.sun.corba.se and its sub-packages have been
  added to the restricted package list and therefore cannot be used directly
  when running with a security manager.

  Workaround:
  Applications running with a security manager that make direct use of classes
  in these JDK internal packages, need to adjust their security policy to
  grant access. See Java Security Policy Files documentation.

  See 8021257.
Comment 3 errata-xmlrpc 2014-01-14 20:03:32 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5

Via RHSA-2014:0027 https://rhn.redhat.com/errata/RHSA-2014-0027.html
Comment 4 errata-xmlrpc 2014-01-14 20:03:49 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 6

Via RHSA-2014:0026 https://rhn.redhat.com/errata/RHSA-2014-0026.html
Comment 6 errata-xmlrpc 2014-01-15 14:20:18 EST
This issue has been addressed in following products:

  Supplementary for Red Hat Enterprise Linux 5
  Supplementary for Red Hat Enterprise Linux 6

Via RHSA-2014:0030 https://rhn.redhat.com/errata/RHSA-2014-0030.html
Comment 7 errata-xmlrpc 2014-01-27 14:57:09 EST
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5
  Red Hat Enterprise Linux 6

Via RHSA-2014:0097 https://rhn.redhat.com/errata/RHSA-2014-0097.html
Comment 9 errata-xmlrpc 2014-02-04 14:38:54 EST
This issue has been addressed in following products:

  Supplementary for Red Hat Enterprise Linux 5
  Supplementary for Red Hat Enterprise Linux 6

Via RHSA-2014:0135 https://rhn.redhat.com/errata/RHSA-2014-0135.html
Comment 10 errata-xmlrpc 2014-02-04 14:42:52 EST
This issue has been addressed in following products:

  Supplementary for Red Hat Enterprise Linux 5
  Supplementary for Red Hat Enterprise Linux 6

Via RHSA-2014:0134 https://rhn.redhat.com/errata/RHSA-2014-0134.html
Comment 11 errata-xmlrpc 2014-04-17 07:44:22 EDT
This issue has been addressed in following products:

  Oracle Java for Red Hat Enterprise Linux 6
  Oracle Java for Red Hat Enterprise Linux 5

Via RHSA-2014:0414 https://rhn.redhat.com/errata/RHSA-2014-0414.html
Comment 12 errata-xmlrpc 2014-06-10 09:13:27 EDT
This issue has been addressed in following products:

  Supplementary for Red Hat Enterprise Linux 7

Via RHSA-2014:0705 https://rhn.redhat.com/errata/RHSA-2014-0705.html
Comment 13 errata-xmlrpc 2014-07-29 11:41:47 EDT
This issue has been addressed in following products:

  Red Hat Network Satellite Server v 5.4
  Red Hat Network Satellite Server v 5.5
  Red Hat Satellite Server v 5.6

Via RHSA-2014:0982 https://rhn.redhat.com/errata/RHSA-2014-0982.html
Comment 14 Kurt Seifried 2015-07-15 21:23:28 EDT
Mitigation:

Applications running with a security manager that make direct use of classes
in these JDK internal packages, need to adjust their security policy to
grant access. See Java Security Policy Files documentation.

Note You need to log in before you can comment on or make changes to this bug.