Bug 1053301 - PHP 5.3 with XDebug enabled always returns '200 OK' status despite PHP syntax error
Summary: PHP 5.3 with XDebug enabled always returns '200 OK' status despite PHP syntax...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: php   
(Show other bugs)
Version: 6.5
Hardware: All
OS: All
unspecified
low
Target Milestone: rc
: ---
Assignee: Web Stack Team
QA Contact: Martin Kyral
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-15 00:11 UTC by Vojtech Vitek
Modified: 2015-03-04 23:58 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1020221
Environment:
Last Closed: 2014-10-14 06:37:27 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1465 normal SHIPPED_LIVE php bug fix update 2014-10-14 01:10:51 UTC
Xdebug 587 None None None Never
PHP Bug Tracker 50921 None None None Never
Red Hat Bugzilla 1020221 None CLOSED Always returns 200 for php cartridge even though php page has syntax error. 2019-01-11 19:01 UTC

Internal Trackers: 1020221

Comment 2 Remi Collet 2014-01-15 05:41:05 UTC
Upstream fix: http://git.php.net/?p=php-src.git;a=patch;h=09607226d4d418421119736f8137189efc4602ff


This upstream fix is 5.4 only because it introduce an internal API change, so not acceptable in a stable branch.

Backporting this, in RHEL, will cause a small ABI change which is not expected.

Even with this backported, XDebug will not take benefit of this, as it only use it when build against PHP >= 5.4.

Comment 3 Remi Collet 2014-01-15 05:48:38 UTC
Notice: XDebug is not part of RHEL supported package (only in EPEL), and is a developer tool which shouldn't be enabled on a production server.

Comment 14 errata-xmlrpc 2014-10-14 06:37:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1465.html

Comment 15 Remi Collet 2014-11-13 10:32:12 UTC
For memory, php-pecl-xdebug-2.1.4-2 (in EPEL) will take benefit of this change.

https://admin.fedoraproject.org/updates/php-pecl-xdebug-2.1.4-2.el6


Note You need to log in before you can comment on or make changes to this bug.