Bug 1053314 - 404 error on app after git push and application restart
Summary: 404 error on app after git push and application restart
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Image
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Dan McPherson
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-15 02:23 UTC by Rich Hildred
Modified: 2015-05-15 00:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-15 14:35:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Rich Hildred 2014-01-15 02:23:01 UTC
Description of problem:

I do a git push on ssh://52d599975004460dbe0000be@derbytest-syndicateme.rhcloud.com/~/git/derbytest.git/ now when I surf to http://derbytest-syndicateme.rhcloud.com I get redirected to https://derbytest-syndicateme.rhcloud.com/app and a 404 error

Version-Release number of selected component (if applicable):


How reproducible:

It is in that state 100% of the time right now. Doesn't seem to have been cured by app restart.

Steps to Reproduce:
1. git push on ssh://52d599975004460dbe0000be@derbytest-syndicateme.rhcloud.com/~/git/derbytest.git/
2. surf to http://derbytest-syndicateme.rhcloud.com

Actual results:

Get redirected to https://derbytest-syndicateme.rhcloud.com/app and 404 error


Expected results:

<!Doctype html>
<html><head><title>Rich Rocks</title></head>
<body><h1>Rich Rocks!</h1></body>
</html>

Additional info:

Comment 1 Rich Hildred 2014-01-15 02:33:06 UTC
Interestingly ... If I do a curl http://127.8.66.1:8080 from my gear

based on:

OPENSHIFT_JBOSSEWS_IP=127.8.66.1
and
OPENSHIFT_JBOSSEWS_HTTP_PORT=8080

I get my expected results back.

<!Doctype html>
<html><head><title>Rich Rocks</title></head>
<body><h1>Rich Rocks!</h1></body>

So the issue seems to be between my tomcat instance and the proxy

Comment 2 Jakub Hadvig 2014-01-15 12:43:30 UTC
Hi Rich,
thank you for reporting this issue.
Could you please add some more detail steps about how to reproduce this issue ?
For example:
 - that kind of cartridges are you using for your application.
 - if you scale your application.
 - ...

There is now way for us to reproduce this issue from the steps you discribed in the Bug Description.

Thank you.

-Jakub

Comment 3 Rich Hildred 2014-01-15 13:24:45 UTC
Hi Jakub:

I also cannot reproduce this issue today. It seems to have started serving my app again, as of this morning.

thanks

Rich


Note You need to log in before you can comment on or make changes to this bug.