Bug 1053324 - Apcupsd prints to stdout unnecessarily
Summary: Apcupsd prints to stdout unnecessarily
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apcupsd
Version: 20
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Michal Hlavinka
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1070511 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-15 02:51 UTC by Larkin Lowrey
Modified: 2014-04-14 22:36 UTC (History)
2 users (show)

Fixed In Version: apcupsd-3.14.12-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-14 22:32:41 UTC


Attachments (Terms of Use)

Description Larkin Lowrey 2014-01-15 02:51:33 UTC
Description of problem:
When connecting via SNMP, apcupsd prints SNMP debug info to stdout which ends up polluting my /var/log/messages.

I sent an email to the upstream mailing list but got no response.

Version-Release number of selected component (if applicable):
apcupsd-3.14.10-13.fc20.x86_64

How reproducible:
Every time. Easy.

Steps to Reproduce:
1. Set the following in apcupsd.conf:
    UPSCABLE ether
    UPSTYPE snmp
    DEVICE host.domain.com:161:APC:public
2. Start apcupsd daemon
3. Watch /var/log/messages for output per 'Actual results' below.

Actual results:
Jan 14 20:38:57 fubar apcupsd: OBJECTID
Jan 14 20:38:57 fubar apcupsd: INTEGER
Jan 14 20:38:57 fubar apcupsd: SEQUENCE
Jan 14 20:38:57 fubar apcupsd: OBJECTID
Jan 14 20:38:57 fubar apcupsd: INTEGER
Jan 14 20:38:57 fubar apcupsd: SEQUENCE
Jan 14 20:38:57 fubar apcupsd: OBJECTID
Jan 14 20:38:57 fubar apcupsd: INTEGER
Jan 14 20:38:57 fubar apcupsd: SEQUENCE
Jan 14 20:38:57 fubar apcupsd: OBJECTID
Jan 14 20:38:57 fubar apcupsd: OCTETSTRING
...etc...


Expected results:
No output in /var/log/messages from apcuspd during normal polling.

Additional info:
The problem lies in src/drivers/snmplite/asn.cpp. The debug method should either be removed or made conditional. There is another printf in Object::Demarshal.

Comment 1 Michal Hlavinka 2014-01-21 16:47:48 UTC
please test if these packages fix issue for you:
http://kojipkgs.fedoraproject.org//work/tasks/5274/6435274/

Comment 2 Larkin Lowrey 2014-01-22 03:13:36 UTC
Success! I installed the fix rpms and no longer see the debug output in /var/log/messages. Thank you.

Comment 3 Fedora Update System 2014-01-23 11:33:37 UTC
apcupsd-3.14.10-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/apcupsd-3.14.10-11.fc19

Comment 4 Fedora Update System 2014-01-23 11:33:45 UTC
apcupsd-3.14.10-14.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/apcupsd-3.14.10-14.fc20

Comment 5 Fedora Update System 2014-01-24 07:36:19 UTC
Package apcupsd-3.14.10-14.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing apcupsd-3.14.10-14.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1405/apcupsd-3.14.10-14.fc20
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-02-17 16:35:03 UTC
apcupsd-3.14.11-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/apcupsd-3.14.11-1.fc19

Comment 7 Fedora Update System 2014-02-17 16:35:18 UTC
apcupsd-3.14.11-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/apcupsd-3.14.11-1.fc20

Comment 8 Philip Prindeville 2014-02-27 02:07:47 UTC
*** Bug 1070511 has been marked as a duplicate of this bug. ***

Comment 9 Fedora Update System 2014-04-14 22:32:41 UTC
apcupsd-3.14.12-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2014-04-14 22:36:26 UTC
apcupsd-3.14.12-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.