Bug 105335 - bind 9.2.1-9 Segmentation Fault
bind 9.2.1-9 Segmentation Fault
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-24 22:19 EDT by DIanne Skoll
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-25 03:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Tcpdump of traffic that crashed bind-9.2.1-9 (1.38 KB, application/octet-stream)
2003-09-24 22:21 EDT, DIanne Skoll
no flags Details

  None (edit)
Description DIanne Skoll 2003-09-24 22:19:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
Named segfaults when I run:

host groups.google.com

gdb stack trace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 8194 (LWP 2737)]
0x4007b4bd in getname () from /usr/lib/libdns.so.5
(gdb) where
#0  0x4007b4bd in getname () from /usr/lib/libdns.so.5
#1  0x4007bd80 in getsection () from /usr/lib/libdns.so.5
#2  0x4007c8d8 in dns_message_parse () from /usr/lib/libdns.so.5
#3  0x400dfde0 in resquery_response () from /usr/lib/libdns.so.5
#4  0x4023f339 in dispatch () from /usr/lib/libisc.so.4
#5  0x4023f461 in run () from /usr/lib/libisc.so.4
#6  0x40275941 in pthread_start_thread () from /lib/i686/libpthread.so.0
#7  0x40275a45 in pthread_start_thread_event () from /lib/i686/libpthread.so.0


Version-Release number of selected component (if applicable):
9.2.1-9

How reproducible:
Didn't try


Additional info:

I have a TCP dump at http://www.roaringpenguin.com/bind-crash.tcpdump that shows
the packets being exchanged.  It was produced with "tcpdump -w"; you can open it
with Ethereal or tcpdump -r.

I rated this as "security" because a segfault in named makes me very, very, very
nervouse...
Comment 1 DIanne Skoll 2003-09-24 22:21:18 EDT
Created attachment 94705 [details]
Tcpdump of traffic that crashed bind-9.2.1-9

This tcpdump was created using "tcpdump -s 1500 -w filename -i ppp0 port 53" 
You can look at it with ethereal or "tcpdump -r"
Comment 2 DIanne Skoll 2003-09-24 22:44:37 EDT
Never mind... my /usr/lib/libdns.so.5.0.3 had somehow become modified.  I need
to figure out how, but reinstalling the RPM fixed it.

Note You need to log in before you can comment on or make changes to this bug.