Bug 1053565 - oxygen-gtk crashes eclipse
Summary: oxygen-gtk crashes eclipse
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: oxygen-gtk2
Version: 20
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch, Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-15 12:28 UTC by Harald Reindl
Modified: 2014-12-22 02:31 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-11-01 16:52:41 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 339174 None None None Never

Description Harald Reindl 2014-01-15 12:28:17 UTC
thisis really odd because Eclipse randomly crashes, mostly if you use *any* close button like STRG+F and close the search window and some other places

these are completly unexpected things if someone updates to Fedora 20 while there is no major change in the used software except libraries

https://bugs.launchpad.net/ubuntu/+source/java-common/+bug/1205452
https://bugs.launchpad.net/ubuntu/+source/java-common/+bug/1205452/comments/7
http://forums.zend.com/viewtopic.php?f=59&t=114903

# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f710f967b48, pid=10954, tid=140124135044864
#
# JRE version: OpenJDK Runtime Environment (7.0_45-b15) (build 1.7.0_45-mockbuild_2014_01_06_16_22-b00)
# Java VM: OpenJDK 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libgobject-2.0.so.0+0x19b48]  g_object_get_qdata+0x18
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/jvm-10954/hs_error.log
Compiled method (nm)   45799  890     n       org.eclipse.swt.internal.gtk.OS::_g_object_get_qdata (native)
 total in heap  [0x00007f7125341750,0x00007f7125341ad0] = 896
 relocation     [0x00007f7125341870,0x00007f71253418d0] = 96
 main code      [0x00007f71253418e0,0x00007f7125341ad0] = 496
#

Comment 1 Harald Reindl 2014-01-15 12:48:46 UTC
here another one
https://bugs.kde.org/show_bug.cgi?id=324438

looks like there is even a patch 
https://bugs.kde.org/show_bug.cgi?id=324438#c36

Comment 2 nucleo 2014-01-15 14:22:36 UTC
oxygen-gtk2-1.4.2 with various fixes should be released soon.

Comment 3 Fedora Update System 2014-01-20 22:30:55 UTC
oxygen-gtk2-1.4.2-1.fc20,oxygen-gtk3-1.3.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/oxygen-gtk2-1.4.2-1.fc20,oxygen-gtk3-1.3.2-1.fc20

Comment 4 Harald Reindl 2014-01-21 13:43:01 UTC
as said while giving karma oxygen-gtk2-1.4.2-1.fc20 works *much* better but sadly not predictable clean enough, however, this update should be pushed because it makes things really better as before

at night i tested all the cases where before in eclipse (Zend Studio 10.5.1 to be precise) and it looked perfect - where i still can repdrocude *unpredictable* a force close if by close the search dialog (CTRL+F), not always, not as i gave karma but that is still critical and may lead to lose changes / work

Comment 5 Harald Reindl 2014-01-21 13:45:06 UTC
in the cases i can reproduce the "force close" it looks like the same issue as before ([libgobject-2.0.so.0+0x19b48)

[harry@rh:~]$ ZendStudio 
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007ffa3e745b48, pid=23538, tid=140713467508480
#
# JRE version: OpenJDK Runtime Environment (7.0_51-b02) (build 1.7.0_51-mockbuild_2014_01_17_13_38-b00)
# Java VM: OpenJDK 64-Bit Server VM (24.45-b08 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libgobject-2.0.so.0+0x19b48]  g_object_get_qdata+0x18
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/jvm-23538/hs_error.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

Comment 6 nucleo 2014-01-21 14:26:30 UTC
See https://bugs.kde.org/show_bug.cgi?id=329814
> the crash also happens with qtcurve and might actually be upstream (gtk or swt)

Comment 7 Harald Reindl 2014-01-21 14:28:30 UTC
i also made a bugreport for "glib2" and cross-linked this one because the named library file due crash in the terminal is from the glib2-package

https://bugzilla.redhat.com/show_bug.cgi?id=1056070

Comment 8 Fedora Update System 2014-01-22 03:06:44 UTC
oxygen-gtk2-1.4.2-1.fc20, oxygen-gtk3-1.3.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Petr Bartos 2014-03-19 13:16:28 UTC
Unfortunately Eclipse is still crashing (when browsing variables during debug) using oxygen-gtk2-1.4.2-1.fc20 and oxygen-gtk3 1.3.3-3.fc20:

# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00000032328570c2, pid=10238, tid=140561260758784
#
# JRE version: OpenJDK Runtime Environment (7.0_51-b31) (build 1.7.0_51-mockbuild_2014_01_31_16_21-b00)
# Java VM: OpenJDK 64-Bit Server VM (24.51-b03 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libgtk-x11-2.0.so.0+0x2570c2]  gtk_tree_view_get_background_area+0xb2
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

Comment 10 Graham White 2014-03-27 10:56:48 UTC
Still crashing for me on F20.  I have oxygen-gtk2-1.4.2-1.fc20.x86_64 and oxygen-gtk3-1.3.3-3.fc20.x86_64.

Comment 11 Graham White 2014-03-31 10:36:37 UTC
Reverting to the latest oxygen-gtk* packages in the updates repo for Fedora 19 appears to cure the issue for me.

Comment 12 Graham White 2014-03-31 12:46:24 UTC
Sorry, I lied.  Still crashing after downgrading oxygen-gtk*.  I've now reverted back to the Fedora 19 versions of gtk2-* as well and still seeing crashes.  Unfortunately, glib is a little more involved to downgrade as well but it's certainly looking like an upstream bug here.

Comment 13 Massimiliano 2014-10-06 09:24:43 UTC
It seems there is a patch for recent eclipse crash, see:
https://bugs.kde.org/show_bug.cgi?id=339174

The patch applyes if you have in your log:

void Oxygen::ComboBoxData::setButton(GtkWidget*): Assertion `!_button._widget' failed.

Can we reopen this bug or do we need a new one?

Comment 14 Rex Dieter 2014-10-06 11:47:35 UTC
May as well recycle this bug, re-opening.

Comment 15 Rex Dieter 2014-10-06 11:49:28 UTC
In case no new release happens soon, upstream commits are:

oxygen-gtk2:
http://commits.kde.org/oxygen-gtk/1d25c917611546a944d3aee56fc792c4eab87d89

oxygen-gtk3: 
http://commits.kde.org/oxygen-gtk/68e4caa170f6103cd4a2b5e51a14190dc1fa6cbf

Comment 16 Massimiliano 2014-10-25 21:07:18 UTC
This bug ha been fixed in F21. Now I get in my log:

Oxygen::WindowManager::wmButtonPress - warning: a button was already set for this combobox

Eclipse doesn't crash anymore.

$ rpm -qa oxygen-gtk*
oxygen-gtk-1.2.0-6.fc21.noarch
oxygen-gtk2-1.4.6-1.fc21.x86_64
oxygen-gtk3-1.4.1-1.fc21.x86_64

Comment 17 Fedora Update System 2014-10-25 21:10:49 UTC
oxygen-gtk2-1.4.6-1.fc21, oxygen-gtk3-1.4.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/FEDORA-2014-13526/oxygen-gtk2-1.4.6-1.fc21,oxygen-gtk3-1.4.1-1.fc21

Comment 18 Massimiliano 2014-10-31 13:53:17 UTC
Just tested with F20 and Eclipse Luna Service Release 1 (4.4.1). No more crashes, the same warning in log as above.

$ rpm -q oxygen-gtk2
oxygen-gtk2-1.4.6-1.fc20.x86_64

Comment 19 Fedora Update System 2014-11-01 16:52:41 UTC
oxygen-gtk2-1.4.6-1.fc21, oxygen-gtk3-1.4.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Lipeng Wang 2014-12-22 02:31:39 UTC
But it still crash in my Fedora21, here is the info:

[will@will DeviceQuery]$ /usr/local/cuda-6.5/bin/nsight 
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
CompilerOracle: exclude java/lang/reflect/Array.newInstance
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fcfd8db9ebd, pid=8055, tid=140531122136832
#
# JRE version: Java(TM) SE Runtime Environment (8.0_20-b26) (build 1.8.0_20-b26)
# Java VM: Java HotSpot(TM) 64-Bit Server VM (25.20-b23 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libgobject-2.0.so.0+0x32ebd]  g_type_check_instance_is_fundamentally_a+0xd
#


I am using Fedora21 with KDE. 

the xoygen-gtk version:

rpm -qa oxygen-gtk*
oxygen-gtk3-1.4.1-3.fc21.x86_64
oxygen-gtk-1.2.0-6.fc21.noarch
oxygen-gtk2-1.4.6-1.fc21.x86_64


Note You need to log in before you can comment on or make changes to this bug.