Bug 10536 - News service is broken
Summary: News service is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: inn   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-03 07:45 UTC by odaf
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-03 15:10:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description odaf 2000-04-03 07:45:34 UTC
Trying to run /etc/rc.d/inet.d/innd produces nothing. The reason is that
in Red Hat 6.2 some files that in 6.1 were in /usr/lib/news are now in
/usr/lib. The innd script check the existence of /usr/lib/news and as it
doesn't exist in Red Hat 6.2 it don't run.

--- from /etc/rc.d/inet.d/innd ----
[ -d /etc/news ] || exit 0
[ -d /usr/lib/news ] || exit 0
[ -d /var/spool/news ] || exit 0

-----------------------------------

Removing the second check is enough to get the script running.

Finally, thanks for a good job, continue doing it please.

Comment 1 Bill Nottingham 2000-04-03 15:10:59 UTC
Arrgh. Fixed in inn-2.2.2-4; thanks for bringing it to our
attention.

Comment 2 Terje Trane 2001-05-16 13:41:58 UTC
See Bug#: 20720.
/usr/lib/news is changed to /var/lib/news


Note You need to log in before you can comment on or make changes to this bug.