Bug 1053734 - RFE: packstack and foreman should install the rhos sos plugins on all nodes
Summary: RFE: packstack and foreman should install the rhos sos plugins on all nodes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack
Version: 4.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: z1
: 5.0 (RHEL 7)
Assignee: Gaël Chamoulaud
QA Contact: Udi
URL:
Whiteboard:
: 1076299 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-15 17:05 UTC by Udi
Modified: 2014-09-30 17:50 UTC (History)
11 users (show)

Fixed In Version: openstack-packstack-2014.1.1-0.37.dev1238.el7ost
Doc Type: Enhancement
Doc Text:
With this enhancement, PackStack now consistently performs the installation of the sos, sos-plugins-openstack and rhos-collector packages on all hosts.
Clone Of:
: 1131619 1131621 1131647 (view as bug list)
Environment:
Last Closed: 2014-09-30 17:50:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 102481 0 None None None Never
Red Hat Product Errata RHBA-2014:1324 0 normal SHIPPED_LIVE openstack-packstack and openstack-puppet-modules bug fix advisory 2014-09-30 21:49:21 UTC

Description Udi 2014-01-15 17:05:11 UTC
Description of problem:
For the log collector tool to work out of the box for users who use packstack or foreman, the default installation on all nodes should also include the sos plugins package.


How reproducible:
100%


Steps to Reproduce:
1. Install with packstack or foreman
2. run the log collector tool


Actual results:
Logs are collected without any rhos-related info, because we are relying on the user to install the sos plugins on all their openstack nodes prior to running the log collector.


Expected results:
Since it's part of our strategy, we should include it in our easy installation tools instead of just documenting it as a requirement.


Additional info:
Currently, the requirement should be documented in the KB.

Comment 2 Gaël Chamoulaud 2014-06-25 10:09:20 UTC
Patch proposed for review => https://review.openstack.org/102481

Comment 4 Martin Magr 2014-07-28 12:00:23 UTC
*** Bug 1076299 has been marked as a duplicate of this bug. ***

Comment 8 Udi 2014-09-23 12:24:50 UTC
It was fixed for packstack only. With foreman, sos was not installed at all, and no openstack plugins or rhos-log-collector either.

Comment 9 Martin Magr 2014-09-23 14:05:54 UTC
This bug is for openstack-packstack. Please clone this bug for OFI.

Comment 10 Udi 2014-09-23 15:42:58 UTC
Bug 1131647 exists for staypuft. This bug is verified for this version of packstack.

Comment 12 errata-xmlrpc 2014-09-30 17:50:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1324.html


Note You need to log in before you can comment on or make changes to this bug.