Bug 105401 - Recent versions of Gimp-Print CUPS drivers fail to work with installed CUPS
Recent versions of Gimp-Print CUPS drivers fail to work with installed CUPS
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-25 15:03 EDT by Dennis Grant
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 09:21:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Grant 2003-09-25 15:03:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.1a) Gecko/20020614

Description of problem:
Started with RH 8.0

Attempting to use latest version of Gimp-print drivers to improve quality with
Espon C82 printer.

Built both Gimp-print 4.3.20 and Gimp-print 4.3.21 from source

Driver built and installed correctly. CUPS saw and recognised drivers, and
allowed printer to be created. Test pages failed though, with the problem that
the MediaType variable was not getting set.

Much wringing of hands between myself and Gimp-print maintainer.

Attempted to install RawHide CUPS 1.1.19, had exact same problem (gimp-print
4.3.20) Attempted to build 4.3.21, but build failed due to mismatch in libcrypto
versions. Backed out CUPS to 1.1.17 RH8 update, built Gimp-print 4.3.21, same
problem.

Installed ESP Ghostscript V7.07 (from rpm on CUPS website) along with
Ghostscript-cups driver. Then built CUPS 1.1.19 from source.

This worked. Printing now functioning as expected.

It seems that there is something in the way CUPS is built in the Red Hat RPMs
that interferes with the way messages are passed between CUPS and the Gimp-print
drivers. Whatever it is, it was fixed by building CUPS from vanilla source.

I suggest you follow up with Gimp-print maintainer Robert Kravitz. He has my
error logs, and a FAR better idea of how CUPS interoperates with the Gimp-print
drivers.

Note: Gimp-print 4.3.21 works very well with the Espon C82, now that the colours
are mostly tuned. Consider making CUPS+most recent Gimp-print the default RH10
printing system.

DG

Version-Release number of selected component (if applicable):
cups 1.1.17 and higher

How reproducible:
Always

Steps to Reproduce:
1.Download Gimp-print V4.3.21 to otherwise vanilla RH8.0 with CUPS active

2. configure --prefix=/usr --with-gimp --with-ghostscript --with-cups
--with-foomatic=no

3. make, make install

4. /sbin/service cups stop

5. Edit /etc/cups/cupsd.conf and set loglevel to debug2

6. /sbin/service cups start

7. Use CUPS web interface to create a new printer on ESPON lp0, use Gimp-print
driver for C82

8. Attempt to print test page via CUPS web interface

9. observe error in /var/log/cups/error_log  
    

Actual Results:  Test page does not print, error message in CUPS error log

Expected Results:  CUPS test page should have printed

Additional info:

To fix:

1) Download ESP Ghostscript and Ghostscript-CUPS drivers from www.cups.org.
Install RPMs.

2) Download CUPS source from www.cups.org. configure ; make ; make install

3) Download and build gimp-print 4.3.21 from Sourceforge, configure and build as
per steps to reproduce

4) Start CUPS, configure printer as per steps to reproduce

5) Print test page, note success
Comment 1 Tim Waugh 2003-09-29 06:45:50 EDT
gimp-print 4.3.x is a development version!  We won't be shipping that.
Comment 2 Dennis Grant 2003-09-29 07:53:35 EDT
"Development version" is an arbitrary label.

Furthermore, it is the version of the driver that supports the most number of
printers and produces the best quality output.

And finally, the issue involving the non-interaction of it with the Red Hat
packaged version of CUPS is a fault of the CUPS packages, not the gimp-print
version. You're going to have to deal with it eventually, because when the
gimp-print folks bless the "development" code as "release" code, it still ain't
gonna work.

Reopening bug.

DG
Comment 3 Tim Waugh 2003-09-29 09:21:21 EDT
Not my label: see gimp-print.sf.net.  Do the gimp-print people say they want
distributions to ship 4.3.x?  The answer of course is 'no', or else they would
use the (again arbitrary) label 'stable'.

Interaction problems can come from all kinds of sources; we'll deal with them
when we actually ship the versions concerned.

If you happen to know what the problem is, and that it lies with cups, I'd of
course be interested in that.  Also, you can re-open when gimp-print 4.4 is
released.
Comment 4 Dennis Grant 2003-09-29 10:06:08 EDT
Tim, drop a line to Robert Kravitz of Gimp-print. He was the one who advised me
to file a RH bug report.

After you talk to him, you decide if you want to re-open this bug or not.

Printing now works for me, and I did it the hard way....

DG

Note You need to log in before you can comment on or make changes to this bug.