Bug 1054034 - redhat-access-plugin-rhsc: Log in button is NOT working
Summary: redhat-access-plugin-rhsc: Log in button is NOT working
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-access-plugin-rhsc
Version: 2.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 3.0.0
Assignee: Spenser Shumaker
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks: 1035040
TreeView+ depends on / blocked
 
Reported: 2014-01-16 06:26 UTC by Prasanth
Modified: 2015-05-15 17:48 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, if the Cancel button was clicked on the Red Hat Access Login window, it would not allow you to retry logging in to Red Hat Access again by clicking on the "Log in" button. With this release, the Login button works as expected.
Clone Of:
Environment:
Last Closed: 2014-09-22 19:07:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
screensot (34.92 KB, image/png)
2014-01-16 06:26 UTC, Prasanth
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:1277 0 normal SHIPPED_LIVE Red Hat Storage Console 3.0 enhancement and bug fix update 2014-09-22 23:06:30 UTC

Description Prasanth 2014-01-16 06:26:52 UTC
Created attachment 850870 [details]
screensot

Description of problem:

Log in button in the top right corner of "Red Hat Access: Support" page is NOT working.

Version-Release number of selected component (if applicable): 

redhat-access-plugin-rhsc-2.1.2-3.el6rhs.noarch
Red Hat Storage Console Version: 2.1.2-0.33.el6rhs


How reproducible: 100%


Steps to Reproduce:
1. Click on Cluster or Hosts tab and select any Cluster or Host
2. Click on "Red Hat Access: Support"
3. When the login pop-up appears, click on "Cancel"
4. Now click on "Please click to login to redhat.com" in the top right corner and click on "Log in".

Actual results: The log in link is not taking us to the login page anymore. I could see the following in the logs:

-----------------
WARN  Thu Jan 16 11:42:10.395 IST 2014 [27.0.0.1:8702-8] [SynchronousDispatcher    ] Unknown exception while executing GET /hosts
java.lang.IllegalStateException: JBWEB000212: Session already invalidated
        at org.apache.catalina.session.StandardSession.setAttribute(StandardSession.java:1267)
        at org.apache.catalina.session.StandardSession.setAttribute(StandardSession.java:1233)
        at org.apache.catalina.session.StandardSessionFacade.setAttribute(StandardSessionFacade.java:130)
        at org.ovirt.engine.api.common.security.auth.SessionUtils.setEngineSessionId(SessionUtils.java:74)
        at org.ovirt.engine.api.common.security.auth.Challenger.executeBasicAuthentication(Challenger.java:194)
        at org.ovirt.engine.api.common.security.auth.Challenger.preProcess(Challenger.java:116)
        at org.jboss.resteasy.core.ResourceMethod.invokeOnTarget(ResourceMethod.java:252)
        at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:227)
        at org.jboss.resteasy.core.ResourceMethod.invoke(ResourceMethod.java:216)
        at org.jboss.resteasy.core.SynchronousDispatcher.getResponse(SynchronousDispatcher.java:542)
        at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:524)
        at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:126)
        at org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:208)
        at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:55)
        at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:50)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:847)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:295)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:214)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:230)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:149)
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:499)
        at org.jboss.as.web.security.SecurityContextAssociationValve.invoke(SecurityContextAssociationValve.java:169)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:145)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:97)
        at org.jboss.web.rewrite.RewriteValve.invoke(RewriteValve.java:466)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:102)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:336)
        at org.apache.coyote.ajp.AjpProcessor.process(AjpProcessor.java:488)
        at org.apache.coyote.ajp.AjpProtocol$AjpConnectionHandler.process(AjpProtocol.java:420)
        at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:920)
        at java.lang.Thread.run(Thread.java:744)
-------------------


Expected results: The login page should pop-up once you click on "Please click to login to redhat.com"


Additional info: Screenshot attached

Comment 1 Dusmant 2014-01-16 14:35:14 UTC
There is a workaround for this -- If you close that window and bring it up again, you would be able to log in (unless otherwise, you are going to cancel again -- which is a purely ve test case and that fails )

Comment 2 Shalaka 2014-02-12 10:18:16 UTC
Please review the edited doc text.

Comment 3 Spenser Shumaker 2014-02-12 15:45:29 UTC
Approved

Comment 4 Prasanth 2014-05-26 08:20:55 UTC
Verified as fixed in redhat-access-plugin-rhsc-3.0-0.el6rhs.noarch

Comment 5 Pavithra 2014-07-09 05:31:41 UTC
Hi,
Please review the edited text for technical accuracy and sign off.

Comment 6 Spenser Shumaker 2014-07-09 05:52:28 UTC
Text Looks good

Comment 7 Spenser Shumaker 2014-07-09 06:00:29 UTC
My previous comment was inaccurate, I was looking at the wrong field for the fixed-in version. The current text is appropriate.

Comment 9 errata-xmlrpc 2014-09-22 19:07:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1277.html


Note You need to log in before you can comment on or make changes to this bug.