Bug 1054772 - Local addressbooks created without relative_uri set
Summary: Local addressbooks created without relative_uri set
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution
Version: 6.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Matthew Barnes
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-17 12:55 UTC by Siddharth
Modified: 2018-12-04 17:01 UTC (History)
5 users (show)

Fixed In Version: evolution-2.32.3-32.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:41:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1416 normal SHIPPED_LIVE evolution bug fix update 2014-10-14 00:55:22 UTC
GNOME Bugzilla 644107 None None None Never

Description Siddharth 2014-01-17 12:55:07 UTC
Description of problem:
- Not able to delete address book from evolution.
- While deletion of address book from evolution it throws pop-up window with following message "Could not remove address book"
- Also the contacts from one address book can edit/delete from other address book

Version-Release number of selected component (if applicable):
evolution-2.28.3-30.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open evolution client
2. Add new address book File --> New --> Address-book
3. Right click on address book --> Delete  
4. A pop up window with error message appears. 

Actual results:
address book not deleted

Expected results:
address book should be deleted

Additional info:

Comment 2 Milan Crha 2014-01-17 13:21:09 UTC
Upstream bug contains a fix, together with a workaround.

Comment 5 Milan Crha 2014-01-20 12:35:39 UTC
For easier later lookup, the upstream fix requires [1] to be applied first, and then only some chunks with white-space differences will be rejected:

[1] https://git.gnome.org/browse/evolution/commit/?id=8e33ff0fbb5908

Comment 8 RHEL Product and Program Management 2014-04-07 21:51:22 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 13 errata-xmlrpc 2014-10-14 04:41:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1416.html


Note You need to log in before you can comment on or make changes to this bug.