Bug 1054809 - JMS errror in mulitApp demo client
Summary: JMS errror in mulitApp demo client
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples
Version: 6.0.0 GA
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: CR2
: 6.0.0
Assignee: Keith Babo
QA Contact: Jiri Sedlacek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-17 14:05 UTC by Jiri Pechanec
Modified: 2015-08-02 23:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The Camel JmsBinding formerly expected the message body returned to be a DOMSource, causing it to convert the response into an InputStream and create a BytesMessage. The body is now a Node, causing it to choose a TextMessage. As a result, mvn exec:java throws an exception.
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker SWITCHYARD-1920 0 Major Closed SOAP MessageComposer creates DOMSource without Document element 2014-06-16 23:53:26 UTC
Red Hat Issue Tracker SWITCHYARD-1933 0 Major Closed multiApp order-consumer client receives TextMessage and not BytesMessage 2014-06-16 23:50:46 UTC

Description Jiri Pechanec 2014-01-17 14:05:14 UTC
mvn exec:java throws an exception
java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.codehaus.mojo.exec.ExecJavaMojo$1.run(ExecJavaMojo.java:297)
	at java.lang.Thread.run(Thread.java:724)
Caused by: java.lang.ClassCastException: org.hornetq.jms.client.HornetQTextMessage cannot be cast to javax.jms.BytesMessage
	at org.switchyard.quickstarts.demo.multiapp.consumer.OrderIntakeClient.main(OrderIntakeClient.java:62)
	... 6 more

The test client expects ByteMessage but TextMessage is received instead of it.

Comment 1 kconner 2014-01-17 18:48:09 UTC
This occurs because the Camel JmsBinding now makes a different determination about the type of JMS message to be sent.

In ER8 the body returned was a DOMSource, causing it to convert the response into an InputStream and create a BytesMessage.  In CR1 the body is now a Node, causing it to choose a TextMessage.

This is probably due to SWITCHYARD-1920

Comment 2 kconner 2014-01-17 20:15:15 UTC
PR has been added for the changes

Comment 3 Jiri Pechanec 2014-01-24 10:52:49 UTC
Verified in CR2

Comment 4 JBoss JIRA Server 2014-06-16 23:50:47 UTC
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1933 to Closed

Comment 5 JBoss JIRA Server 2014-06-16 23:53:27 UTC
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1920 to Closed


Note You need to log in before you can comment on or make changes to this bug.