Bug 1054832 - Firefox does not support Camellia cipher
Summary: Firefox does not support Camellia cipher
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Martin Stransky
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-17 14:53 UTC by Eric Christensen
Modified: 2014-02-27 09:24 UTC (History)
4 users (show)

Fixed In Version: firefox-24.3.0-3.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-27 09:24:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eric Christensen 2014-01-17 14:53:28 UTC
Description of problem: Firefox doesn't seem to support the Camellia cipher, only AES (and RC4).  This is different from Fedora's behavior.  Not sure if this is intentional or not.  This has caused me some problems.

Version-Release number of selected component (if applicable): 24.1.0-3.el7


How reproducible:
Always

Steps to Reproduce:
1. Visit website that only supports Camellia cipher.


Actual results:
Error code: ssl_error_no_cypher_overlap

Expected results:
To connect using Camellia.

Additional info:
Looks like the following ciphers and protocols are supported:

TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA (0xc00a)   Forward Secrecy 	256
TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA (0xc014)   Forward Secrecy 	256
TLS_DHE_RSA_WITH_AES_256_CBC_SHA (0x39)   Forward Secrecy 	256
TLS_DHE_DSS_WITH_AES_256_CBC_SHA (0x38)   Forward Secrecy* 	256
TLS_ECDH_RSA_WITH_AES_256_CBC_SHA (0xc00f) 	256
TLS_ECDH_ECDSA_WITH_AES_256_CBC_SHA (0xc005) 	256
TLS_RSA_WITH_AES_256_CBC_SHA (0x35) 	256
TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA (0xc009)   Forward Secrecy 	128
TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA (0xc013)   Forward Secrecy 	128
TLS_DHE_RSA_WITH_AES_128_CBC_SHA (0x33)   Forward Secrecy 	128
TLS_DHE_DSS_WITH_AES_128_CBC_SHA (0x32)   Forward Secrecy* 	128
TLS_ECDH_RSA_WITH_AES_128_CBC_SHA (0xc00e) 	128
TLS_ECDH_ECDSA_WITH_AES_128_CBC_SHA (0xc004) 	128
TLS_RSA_WITH_AES_128_CBC_SHA (0x2f) 	128

Comment 7 Martin Stransky 2014-02-27 09:24:09 UTC
Added to firefox-24.3.0-3.el7


Note You need to log in before you can comment on or make changes to this bug.