Bug 1054877 - graphviz install step "dot -c" blocked by selinux
Summary: graphviz install step "dot -c" blocked by selinux
Keywords:
Status: CLOSED DUPLICATE of bug 1054350
Alias: None
Product: Fedora
Classification: Fedora
Component: graphviz
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-17 16:24 UTC by John Ellson
Modified: 2014-01-17 22:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-17 22:46:54 UTC
Type: Bug


Attachments (Terms of Use)

Description John Ellson 2014-01-17 16:24:41 UTC
Description of problem:
Some recent selinux update, I assume, is blocking the execution of "dot -c" from the post scripts in the graphviz-plugin-* rpms.
This prevents the creation of /usr/lib64/graphviz/config6 which is used at user runtime to identify all available plugins without loading them every time.

Without this config6 file, dot fails to find its plugins:
   $ echo "digraph {hello->world}" | dot -Tpng >hello.png
   Format: "png" not recognized. Use one of:


Version-Release number of selected component (if applicable):
graphviz-2.34.0-4.fc20.x86_64.rpm

How reproducible:
100%

Steps to Reproduce:
1.setenforce 1
2.yum install graphviz
3.

Actual results:
  Installing : graphviz-2.34.0-4.fc20.x86_64                                1/1 
warning: %post(graphviz-2.34.0-4.fc20.x86_64) scriptlet failed, exit status 127
Non-fatal POSTIN scriptlet failure in rpm package graphviz-2.34.0-4.fc20.x86_64

  
Expected results:
creation of /usr/lib64/grapviz/config6 during install

Additional info:
A workaround for now is to "setenforce 0" during install.

The simplest fix, for me (graphviz upstream), would be if selinux allowed a freshly installed /usr/bin/dot to create /usr/lib*/graphviz/config*

Comment 1 John Ellson 2014-01-17 22:46:54 UTC
ah, I see its not just graphviz ...

*** This bug has been marked as a duplicate of bug 1054350 ***


Note You need to log in before you can comment on or make changes to this bug.