Bug 10549 - Default configuration files for iproute
Default configuration files for iproute
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: iproute (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-03 13:13 EDT by Mihai Ibanescu
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 22:50:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mihai Ibanescu 2000-04-03 13:13:40 EDT
The iproute package should have several configuration files included. By
default, ip looks for files in /etc/iproute2.

The files in /etc/iproute2 are pretty important, because one can define
(for instance) a name for a rule. This is much more human readable.

Example: in /etc/iproute2/rt_tables I can put a line like

16	tunnel.otherisp

in order to make a source routing with other next hops, and then do
something like

ip route show table tunnel.otherisp

instead of the more insipid
ip route show table 16

I guess adding the config files (they are included in Alexei's iproute2
packages) is not difficult, and improves a lot the package.
Comment 1 Cristian Gafton 2000-08-08 22:45:42 EDT
assigned to nalin
Comment 2 Ngo Than 2000-10-12 13:02:58 EDT
It's fixed in iproute-2.2.4-7. You will find it in 7.0 rawhide.

Note You need to log in before you can comment on or make changes to this bug.