Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1054969 - [GTK3] Customize window does not update
Summary: [GTK3] Customize window does not update
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 19
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-17 20:54 UTC by Kevin Brosnan :kbrosnan
Modified: 2014-02-18 02:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-18 02:48:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Kevin Brosnan :kbrosnan 2014-01-17 20:54:15 UTC
Description of problem: The customize window does not update the view when adding or removing buttons from the list until you move another button


Version-Release number of selected component (if applicable): 29a1


How reproducible: Always, using clean profile


Steps to Reproduce:
1. Open Firefox's menu button
2. Select customize
3. Add or remove buttons from the menu
4. buttons disappear after being dropped 

Actual results: Buttons disappear when dropped


Expected results: Buttons reflow the menu and drop in the expected location


Additional info: Mozilla's nightly behaves as expected.

Comment 1 Kevin Brosnan :kbrosnan 2014-01-17 20:58:01 UTC
Videos of the problem. [1] up to date Mozilla build of Nightly [2] GTK3 build from Fedora

[1] - http://people.mozilla.org/~kbrosnan/tmp/fedora-bugs/1054969/GTK2-Firefox-Mozilla.webm

[2] http://people.mozilla.org/~kbrosnan/tmp/fedora-bugs/1054969/GTK3-Firefox.webm

Comment 2 Martin Stransky 2014-02-14 11:22:06 UTC
I'm unable to reproduce with latest firefox-gtk3 build (firefox-gtk3-30.0-2).

Comment 3 Kevin Brosnan :kbrosnan 2014-02-18 02:48:54 UTC
Yeah works for me.


Note You need to log in before you can comment on or make changes to this bug.