Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Created attachment 852002[details]
write.sh reproduces the problem and write.log shows the error
Description of problem:
"targetcli restoreconfig" doesn't always restore all iSCSI portals. This can happen on reboot but also can be triggered manually.
Version-Release number of selected component (if applicable):
Current RHEL7 Beta as of 1/18/14.
uname -r: 3.10.0-54.0.1.el7.x86_64
Version 2.1.fb31 of targetcli (per yum info targetcli)
How reproducible:
The attached tar file contains a script (write.sh) and results (write.log).
Simply execute "bash write.sh" and examine the output. Upon failure, the output will contain one or more lines of the form:
Creating NetworkPortal object 192.168.1.2:3260 failed, skipped
Those lines should not be present and all portals should be correctly restored.
The example log provided has two such failures.
Additional info:
RHEL7 Beta is running within a VirtualBox (4.3.6) VM. The host processor is a Xeon IvyBridge. The host OS is Windows 7 Ultimate.
You can greatly increase the chance of failure by running with a single core. Yes, I know that's not a supported configuration but perhaps it's helpful for debugging.
A kernel patch was submitted against this bug, so this bug needs to be against the kernel component. You'll have to reacquire flags now, unfortunately.
Verified. On kernel-3.10.0-105.el7.x86_64 it was not reproducible.
Easily reproducible on kernel-3.10.0-84.el7.x86_64
Configuration restored, 1 recoverable errors:
Creating NetworkPortal object 192.168.1.2:3260 failed: Could not create NetworkPortal in configFS., skipped
Note: I could reproduce this issue only on virtual machine.
This request was resolved in Red Hat Enterprise Linux 7.0.
Contact your manager or support representative in case you have further questions about the request.
Created attachment 852002 [details] write.sh reproduces the problem and write.log shows the error Description of problem: "targetcli restoreconfig" doesn't always restore all iSCSI portals. This can happen on reboot but also can be triggered manually. Version-Release number of selected component (if applicable): Current RHEL7 Beta as of 1/18/14. uname -r: 3.10.0-54.0.1.el7.x86_64 Version 2.1.fb31 of targetcli (per yum info targetcli) How reproducible: The attached tar file contains a script (write.sh) and results (write.log). Simply execute "bash write.sh" and examine the output. Upon failure, the output will contain one or more lines of the form: Creating NetworkPortal object 192.168.1.2:3260 failed, skipped Those lines should not be present and all portals should be correctly restored. The example log provided has two such failures. Additional info: RHEL7 Beta is running within a VirtualBox (4.3.6) VM. The host processor is a Xeon IvyBridge. The host OS is Windows 7 Ultimate. You can greatly increase the chance of failure by running with a single core. Yes, I know that's not a supported configuration but perhaps it's helpful for debugging.