Bug 1055104 - grub2-mkconfig -o destroys a symlink
Summary: grub2-mkconfig -o destroys a symlink
Keywords:
Status: CLOSED DUPLICATE of bug 743977
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 20
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL: http//
Whiteboard:
Depends On: 1032182
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-18 20:00 UTC by Tomas Dolezal
Modified: 2014-01-20 17:25 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1032182
Environment:
Last Closed: 2014-01-20 17:25:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Tomas Dolezal 2014-01-18 20:00:59 UTC
+++ This bug was initially created as a clone of Bug #1032182 +++

Description of problem:
There is the following symbolic link in the system by default:

/etc/grub2.cfg -> /boot/grub2/grub.cfg

The following command, however, destroys the link by replacing it with a regular file:

mkconfig-grub2 -o /etc/grub2.cfg

Version-Release number of selected component (if applicable):
grub2-2.00-25.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1. make sure that /etc/grub2.cfg is a symlink to /boot/grub2/grub.cfg
2. run mkconfig-grub2 -o /etc/grub2.cfg
3. rpm -V grub2 fails because destination file becomes a regular file with updated content, grub2 is not updated

Actual results:
/etc/grub2.cfg is a regular file

Expected results:
/etc/grub2.cfg is a symlink

Additional info:

Comment 1 Mads Kiilerich 2014-01-18 20:40:23 UTC
It has "always" been that way. It has never been recommended/documented to use the symlink for mkconfig. The symlink is only for grubby.

Comment 2 Michael Schwendt 2014-01-19 08:52:43 UTC
Tomas, see bug 743977 for an older ticket about this.

Comment 3 Brian Lane 2014-01-20 17:25:35 UTC

*** This bug has been marked as a duplicate of bug 743977 ***


Note You need to log in before you can comment on or make changes to this bug.