Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1055221 - SELinux is preventing /usr/bin/Xorg from using the 'sys_rawio' capabilities.
Summary: SELinux is preventing /usr/bin/Xorg from using the 'sys_rawio' capabilities.
Keywords:
Status: CLOSED DUPLICATE of bug 1055211
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:a6a0c0e77d454a15bba98579fb9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-19 15:51 UTC by Zero
Modified: 2014-01-19 18:26 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-19 18:26:11 UTC
Type: ---


Attachments (Terms of Use)

Description Zero 2014-01-19 15:51:14 UTC
Description of problem:
SELinux is preventing /usr/bin/Xorg from using the 'sys_rawio' capabilities.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that Xorg should have the sys_rawio capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep Xorg /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:bumblebee_t:s0
Target Context                system_u:system_r:bumblebee_t:s0
Target Objects                 [ capability ]
Source                        Xorg
Source Path                   /usr/bin/Xorg
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-server-Xorg-1.14.4-5.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-106.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.12.7-300.fc20.x86_64 #1 SMP Fri
                              Jan 10 15:35:31 UTC 2014 x86_64 x86_64
Alert Count                   6
First Seen                    2014-01-14 22:38:09 CET
Last Seen                     2014-01-16 14:31:44 CET
Local ID                      b1db9778-7401-408e-b42f-c64ea53ca2c0

Raw Audit Messages
type=AVC msg=audit(1389879104.64:432): avc:  denied  { sys_rawio } for  pid=2664 comm="Xorg" capability=17  scontext=system_u:system_r:bumblebee_t:s0 tcontext=system_u:system_r:bumblebee_t:s0 tclass=capability


type=SYSCALL msg=audit(1389879104.64:432): arch=x86_64 syscall=ioperm success=yes exit=0 a0=0 a1=400 a2=1 a3=0 items=0 ppid=493 pid=2664 auid=4294967295 uid=0 gid=1001 euid=0 suid=0 fsuid=0 egid=1001 sgid=1001 fsgid=1001 ses=4294967295 tty=(none) comm=Xorg exe=/usr/bin/Xorg subj=system_u:system_r:bumblebee_t:s0 key=(null)

Hash: Xorg,bumblebee_t,bumblebee_t,capability,sys_rawio

Additional info:
reporter:       libreport-2.1.11
hashmarkername: setroubleshoot
kernel:         3.12.7-300.fc20.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2014-01-19 18:26:11 UTC

*** This bug has been marked as a duplicate of bug 1055211 ***


Note You need to log in before you can comment on or make changes to this bug.