Bug 1055322 - anaconda isn't generating an initramfs for all installed kernels
Summary: anaconda isn't generating an initramfs for all installed kernels
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 01:09 UTC by M. Edward (Ed) Borasky
Modified: 2014-03-17 20:25 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-17 20:25:49 UTC
Type: Bug


Attachments (Terms of Use)
screenshot of console log showing missing initramfs (29.76 KB, image/png)
2014-01-20 01:09 UTC, M. Edward (Ed) Borasky
no flags Details
screenshot of main Anaconda screen after completing install (35.46 KB, image/png)
2014-01-20 01:11 UTC, M. Edward (Ed) Borasky
no flags Details
screenshot of Ctl-Alt-F3 log (41.27 KB, image/png)
2014-01-20 01:11 UTC, M. Edward (Ed) Borasky
no flags Details
screenshot of Ctl-Alt-F5 log (38.15 KB, image/png)
2014-01-20 01:12 UTC, M. Edward (Ed) Borasky
no flags Details
zip archive of /mnt/sysimage/var/log/anaconda after an install but before rebooting (112.82 KB, application/zip)
2014-01-21 20:24 UTC, M. Edward (Ed) Borasky
no flags Details
output of 'ls -l /mnt/sysimage/boot' after install before reboot (1.21 KB, text/x-log)
2014-01-21 20:29 UTC, M. Edward (Ed) Borasky
no flags Details

Description M. Edward (Ed) Borasky 2014-01-20 01:09:53 UTC
Created attachment 852580 [details]
screenshot of console log showing missing initramfs

Description of problem: After an install, I get a kernel panic trying to boot up the system. It turns out an initramfs file is missing from /boot


Version-Release number of selected component (if applicable): anaconda-20.25.15-1.fc20.x86_64

Steps to Reproduce:
1. Generate a Fedora remix ISO file using https://github.com/znmeb/CompJournoStick/blob/master/2MakeLiveISOImage/1SudoMakeISOImage.bash
2. Create a virtual machine using Virtual Machine Manager and connect the ISO file to it.
3. Install the remix to the virtual machine.

Actual results:
The install appears to work - I get to the 'Quit' prompt and I can reboot the machine. When it comes back up, the Grub menu shows three options: normal, debug and rescue. Rescue and debug boot up fine, but the normal one crashes instantly with a kernel panic.

I did some digging and it turns out /boot has an initramfs for the rescue and debug kernels, but *not* one for the normal one!


Expected results:
I expected the normal kernel to boot.

Additional info:
See attached screenshots - I don't know how to get log files from Anaconda.

Comment 1 M. Edward (Ed) Borasky 2014-01-20 01:11:03 UTC
Created attachment 852581 [details]
screenshot of main Anaconda screen after completing install

Comment 2 M. Edward (Ed) Borasky 2014-01-20 01:11:40 UTC
Created attachment 852582 [details]
screenshot of Ctl-Alt-F3 log

Comment 3 M. Edward (Ed) Borasky 2014-01-20 01:12:19 UTC
Created attachment 852583 [details]
screenshot of Ctl-Alt-F5 log

Comment 4 M. Edward (Ed) Borasky 2014-01-20 01:18:11 UTC
Comment on attachment 852580 [details]
screenshot of console log showing missing initramfs

there should be a file /boot/initramfs-3.12.7-300.fc20.x86_64.img

Comment 5 M. Edward (Ed) Borasky 2014-01-20 05:39:00 UTC
Note: see Bug 1046246 for why there's both a regular and a debug kernel on the install media and the resulting installed virtual machine.

Comment 6 David Shea 2014-01-21 15:58:03 UTC
Screenshots of log files are not as helpful as log files. Please attach the log files from the installation (in /tmp during the install, saved to /var/log/anaconda in the installed system) to this bug as text/plain attachments.

Comment 7 M. Edward (Ed) Borasky 2014-01-21 20:24:39 UTC
Created attachment 853435 [details]
zip archive of /mnt/sysimage/var/log/anaconda after an install but before rebooting

Comment 8 M. Edward (Ed) Borasky 2014-01-21 20:29:06 UTC
Created attachment 853436 [details]
output of 'ls -l /mnt/sysimage/boot' after install before reboot

Comment 9 M. Edward (Ed) Borasky 2014-01-21 23:02:45 UTC
This could also be some fallout from bug 1054350, which wreaked a lot of havoc on my machine over the weekend. If you want, I can do a 'yum list installed' and see what versions of everything landed on the ISO.

Comment 10 David Shea 2014-03-17 20:25:49 UTC
This was inadvertently fixed in rawhide. In pyanaconda/bootloader.py, writeBootLoader pops the first kernel entry off kernel_versions to use as the default bootloader. In F20, this variable was set with

kernel_versions = payload.kernelVersionList

so kernel_versions.pop was modifying the copy kept in the payload object. In rawhide, it's now set with

kernel_versions = payload.kernelVersionList + payload.rescueKernelList

so it's a new list and modifications don't affect the list used by Payload.recreateInitrds. The property is supposed to be read-only anyway so I'll fix that part of anaconda so that it really is.


Note You need to log in before you can comment on or make changes to this bug.