Bug 1055519 - Invalid shutdown of TimerService thread pool causes thread leak
Summary: Invalid shutdown of TimerService thread pool causes thread leak
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: jBPM Core
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: CR2
: 6.0.0
Assignee: Maciej Swiderski
QA Contact: Jiri Svitak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 13:18 UTC by Maciej Swiderski
Modified: 2015-06-02 01:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:08:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Maciej Swiderski 2014-01-20 13:18:24 UTC
Description of problem:
due to bug introduced by fixing https://bugzilla.redhat.com/show_bug.cgi?id=1036761 the ThreadPoolSchedulerService does not properly shutdown its thread pool causing threads to be left after it RuntimeManager is closed.

Version-Release number of selected component (if applicable):


How reproducible:
Create RuntimeManager with default settings (ThreadPoolSchedulerService with pool size set to 3) then:
- execute process with a timer. 
- examine number of active threads
- close RuntimeManager
- examine number of active threads

last active thread count should not have threads of the scheduler service

Steps to Reproduce:
1.
2.
3.

Actual results:
threads from the scheduler service are still active

Expected results:
threads from scheduler service should not be present

Additional info:

Comment 1 Jiri Svitak 2014-01-20 15:21:12 UTC
Thanks Maciej for reporting this.

Comment 2 Maciej Swiderski 2014-01-21 18:58:06 UTC
fixed on master, waiting for acks to back port

jbpm
master:
https://github.com/droolsjbpm/jbpm/commit/f1d7f2c315535521bd4da980d303877a114264b9

Comment 3 Maciej Swiderski 2014-01-22 16:17:19 UTC
backported to 6.0.x:
https://github.com/droolsjbpm/jbpm/commit/20b457619d4230ace2d3fc47db8033b44fbb4ef2

Comment 4 Edson Tirelli 2014-01-22 22:09:10 UTC
(6.0.0.GA.x): https://github.com/droolsjbpm/jbpm/commit/8436658

Cherry-picked into 6.0.0.CR2.

Comment 5 Jiri Svitak 2014-01-27 18:02:07 UTC
Verified in BPMS 6 CR2.


Note You need to log in before you can comment on or make changes to this bug.