Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1055637 - org-export-as-docbook-pdf: XSLT processor command is not set correctly
Summary: org-export-as-docbook-pdf: XSLT processor command is not set correctly
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: emacs
Version: 20
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Hracek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-20 16:11 UTC by amturnip
Modified: 2014-01-21 09:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-21 09:39:45 UTC
Type: Bug


Attachments (Terms of Use)
Sample emacs document with which to reproduce the problem. (87 bytes, text/plain)
2014-01-20 16:13 UTC, amturnip
no flags Details

Description amturnip 2014-01-20 16:11:10 UTC
Description of problem: 

Emacs' "org-export-as-docbook-pdf" command gives an error, "XSLT processor command is not set correctly". Fedora includes all the necessary packages but does not integrate them.


Version-Release number of selected component (if applicable):

$ rpm -q docbook-style-xsl emacs fop libxslt
docbook-style-xsl-1.78.1-2.fc20.noarch
emacs-24.3-13.fc20.x86_64
fop-1.1-5.fc20.noarch
libxslt-1.1.28-5.fc20.x86_64


How reproducible:

Consistently


Steps to Reproduce:

0.Install packages: docbook-style-xsl fop libxslt

1.emacs a.org (I suppose any org file would equally demonstrate the problem)

2.M-x org-export-as-docbook-pdf


Actual results:

1.Error message: "XSLT processor command is not set correctly" 


Expected results:

1.Happy messages, including 
 * Processing DocBook file...done
 * Exporting to PDF...done
2.Appearance of a.pdf on the disk.


Additional info:

Fedora packages apparently may enrich Emacs' configuration in /usr/share/emacs/site-lisp/.  Such configuration seems to be missing to put Emacs in touch with the Fedora packages it needs.  Something like this...

 (setq org-export-docbook-xsl-fo-proc-command "/usr/bin/fop \"%i\" \"%o\"")

 (setq org-export-docbook-xslt-proc-command "/usr/bin/xsltproc --nonet -o \"%o\" \"%s\" \"%i\"")

 (setq org-export-docbook-xslt-stylesheet "/usr/share/sgml/docbook/xsl-stylesheets/fo/docbook.xsl")

Comment 1 amturnip 2014-01-20 16:13:13 UTC
Created attachment 852801 [details]
Sample emacs document with which to reproduce the problem.

Comment 2 amturnip 2014-01-21 09:39:45 UTC
Oops, no point in bothering. The "latest" Emacs has dropped the DocBook export feature, according to Emacs bug #16506.


Note You need to log in before you can comment on or make changes to this bug.