Bug 1056011 - libglamoregl causes some 3rd party drivers to crash
Summary: libglamoregl causes some 3rd party drivers to crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-glamor
Version: 6.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Jérôme Glisse
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 11:33 UTC by Phil Perry
Modified: 2019-03-22 07:09 UTC (History)
10 users (show)

Fixed In Version: xorg-x11-glamor-0.6.0-5.20140506gitf78901e.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:52:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1376 normal SHIPPED_LIVE xcb-util, xorg-x11-drivers, and mesa bug fix and enhancement update 2014-10-14 01:11:03 UTC

Description Phil Perry 2014-01-21 11:33:39 UTC
Description of problem:

libglamoregl conflicts with some 3rd party drivers causing them to crash.

Version-Release number of selected component (if applicable):

xorg-x11-glamor-0.5.0-6.20130401git81aadb8.el6.x86_64

How reproducible:

intermittent

Steps to Reproduce:
1. Install 3rd party driver (e.g, ATI/AMD or NVIDIA)
2. 
3.

Actual results:


Expected results:


Additional info:

xorg-x11-glamor is automatically installed on RHEL6.5 systems with Xorg as a dependency of xorg-x11-drv-ati which is pulled in by the dummy package xorg-x11-drivers.

However, libglamoregl conflicts with some 3rd party graphics drivers such as the proprietary drivers from ATI/AMD and NVIDIA which can cause Xorg to crash.

libglamoregl is loaded by default from /usr/share/X11/xorg.conf.d/glamor.conf

It is trivial to prevent libglamoregl from loading by editing /usr/share/X11/xorg.conf.d/glamor.conf but because this config file is installed as a regular file any changes will be overwritten as soon as the xorg-x11-glamor package is updated.

Please would you consider making /usr/share/X11/xorg.conf.d/glamor.conf %config(noreplace) so changes to this config file are not overwritten by future updates but are instead installed as .rpmnew

Comment 1 Jérôme Glisse 2014-01-21 19:15:19 UTC
I need to check but i think the issue is that we need to load glamor before the ddx and thus we can not load it from the ddx hence the config option.

If not then we can force load from ddx and drop the configuration files all together.

Comment 2 Phil Perry 2014-04-01 16:38:57 UTC
Jerome,

Any progress on this issue?

Comment 4 Phil Perry 2014-05-22 18:44:00 UTC
This issue is also applicable to the RHEL7 Release Candidate:

xorg-x11-glamor-0.5.1-4.20140115gitfb4d046c.el7.src.rpm

It would be nice if this could be fixed in the next update, and really nice if it didn't also make it into RHEL7.

Do I need to file a separate bug against the RHEL7 RC ?

Comment 9 errata-xmlrpc 2014-10-14 04:52:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1376.html


Note You need to log in before you can comment on or make changes to this bug.