Bug 1056041 - Screen is blurry for some resolutions when spice window is maximized.
Summary: Screen is blurry for some resolutions when spice window is maximized.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.5
Hardware: Unspecified
OS: All
urgent
high
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1081376
TreeView+ depends on / blocked
 
Reported: 2014-01-21 13:05 UTC by Roman Hodain
Modified: 2018-12-05 16:59 UTC (History)
16 users (show)

Fixed In Version: virt-viewer-0.6.0-2.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, SPICE determined the scaling of windows incorrectly by using the original desktop size instead of the host screen size. As a consequence, when a guest window was open in SPICE, the screen could, under certain circumstances, become blurry. With this update, the guest window scaling has been fixed and this problem no longer occurs.
Clone Of:
Environment:
Last Closed: 2014-10-14 06:30:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1379 0 normal SHIPPED_LIVE virt-viewer bug fix update 2014-10-14 01:05:43 UTC

Description Roman Hodain 2014-01-21 13:05:29 UTC
Description of problem:

	The screen of a RHEL KVM guest (gnome) is not sharp when some non
standard resolutions are set. If the resolution is not optimal, the resolution
should be automatically changed +-1 pixel in order to fix it. This procedure
does not work when the spice window is maximized. In this case the screen will
remain blur.


Version-Release number of selected component (if applicable):
All supported Win and RHEL clients

How reproducible:
100% for some resolutions

Steps to Reproduce:
	
	- Install a RHEL system with gnome as a guest in RHEV

	- Connect to the guest via spice from a client (Win7, Fedora 20 tested)

	- Maximize the spice window

	- Change the client panel width (Linux) or the size of the status bar in
	  Windows (it happens just for some sizes It needs to try a couple of
	  sizes)


Actual results:
	The screen is blur

Expected results:
	The screen is sharp

Additional info:

Comment 2 Marc-Andre Lureau 2014-01-21 13:30:11 UTC
this looks very much like bug 1054757.. see also discussion there.

Comment 3 Marc-Andre Lureau 2014-01-21 13:33:27 UTC
I can't reproduce on RHEL6 client, when maximizing client and adjusting gnome panel size, the guest is accordingly resize to fit 1:1 resoution.

I haven't tried with other clients yet.

What version of virt-viewer are you testing?

Comment 4 Roman Hodain 2014-01-21 16:11:19 UTC
(In reply to Marc-Andre Lureau from comment #3)
> I can't reproduce on RHEL6 client, when maximizing client and adjusting
> gnome panel size, the guest is accordingly resize to fit 1:1 resoution.
> 
> I haven't tried with other clients yet.
> 
> What version of virt-viewer are you testing?

Yes that is the point it is re-sized 1:1. The problem does not show al the time. Just for some resolutions. 

virt-viewer-0.5.7-2.fc20.x86_64

Comment 5 Marc-Andre Lureau 2014-01-21 16:13:51 UTC
can you record a screencast showing the problem? thanks

Comment 10 David Jaša 2014-02-05 13:16:32 UTC
I'm able to reproduce on gnome desktop although the bug is sometimes elusive. When the bug occurs, --spice-debug output of remote-viewer contains lines like this:
(remote-viewer:19933): GSpice-DEBUG: spice-widget.c:1046 recalc geom monitor: 0:0, guest +0+0:1280x854, window 1280x853, zoom 1
(remote-viewer:19933): GSpice-DEBUG: spice-widget.c:1046 recalc geom monitor: 0:0, guest +0+0:1920x907, window 1920x905, zoom 1
when the guest height doesn't match window height but in all other cases, the height does match. In addition, when the bug occurs, remote-viewer window contains black bar(s) on the bottom (and sometimes top) edges of the widget, reminding me of bug 810544.

The bug is also not reproducible with all client resolutions:
  * 1280x800: the bug is not reproducible
  * 1280x960: reproducible (with gnome-panel height 29)
  * 1440x900: not reproducible
  * 1600x900: reproducible (gnome-panel height 34)
(the list is not exhaustive)

My setup is nested spice: fedora 20 client connected to rhel6 VM (client VM) connected to another rhel6 VM (guest VM). The test case is to set panel size to default of 28 in client VM, maximize the guest VM window and keep increasing the panel size till the guest gets blurry.

Comment 11 CongDong 2014-02-21 08:47:08 UTC
I cannot reproduce this on rhel6.5 client.

test with:
virt-viewer-0.5.6-9.el6

Steps:
1. start a spice rhel guest
2. # virt-viewer $vm
3. maximize the guest
4. Change the client panel size

Result,
The guest doesn't get blurry.

I test with 1290*1024 and 1680*1050.

Steps above are right?
In comment 10, some resolutions are reproducible, that means a monitor with the same resolution or just change the client's resolution?

Comment 12 Roman Hodain 2014-03-10 08:03:18 UTC
(In reply to CongDong from comment #11)
> I cannot reproduce this on rhel6.5 client.
> 
> test with:
> virt-viewer-0.5.6-9.el6
> 
> Steps:
> 1. start a spice rhel guest
> 2. # virt-viewer $vm
> 3. maximize the guest
> 4. Change the client panel size
> 
> Result,
> The guest doesn't get blurry.
> 
> I test with 1290*1024 and 1680*1050.
> 
> Steps above are right?
> In comment 10, some resolutions are reproducible, that means a monitor with
> the same resolution or just change the client's resolution?

Hi,

Only the quest resolution is changing. 

They to change the size of the client panel by pixel until you face the issue.

Roman

Comment 13 Marc-Andre Lureau 2014-03-11 13:27:42 UTC
I can reproduce, assigning to me

Comment 14 Marc-Andre Lureau 2014-03-11 15:39:32 UTC
sent patch fixing rounding issue:
https://www.redhat.com/archives/virt-tools-list/2014-March/msg00043.html

Comment 18 CongDong 2014-03-28 02:51:08 UTC
I can reproduce this now:
virt-viewer-0.5.6-9.el6_5.x86_64

my physical monitor's resolution is 1680*1050
host and vm are both rhel6u5

Steps:
1. start a spice rhel guest
2. # virt-viewer $vm --debug --spice-debug
3. maximize the guest, and open the display preferences of the guest.
4. keep change(increasing) the client panel size

Result:
I keep increasing the panel size, When the guest resolution is 1680*839, the display is blurry.

Comment 20 CongDong 2014-06-05 07:07:17 UTC
I can reproduce with virt-viewer-0.5.6-10.el6.x86_64

Verify with:
virt-viewer-0.6.0-4.el6.x86_64

1. start a spice rhel guest
2. # virt-viewer $vm --debug --spice-debug
3. maximize the guest, and open the display preferences of the guest.
4. keep change(increasing) the client panel size

Result, the display is always clear.

As the result, VERIFIED.

Comment 21 errata-xmlrpc 2014-10-14 06:30:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html


Note You need to log in before you can comment on or make changes to this bug.