Bug 105618 - Boot disk crashes/reboots machine - machine then fails self tests
Boot disk crashes/reboots machine - machine then fails self tests
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-09-25 20:04 EDT by John William
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:41:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Boot log from serial console (3.86 KB, text/plain)
2003-09-26 20:27 EDT, John William
no flags Details

  None (edit)
Description John William 2003-09-25 20:04:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
When booting from the floppy boot disk, the machine gets past the "Loading 
initrd..." and the kernel starts running. Some text briefly flickers on the 
screen (looks like memory probing) and then the machine reboots. The time 
between the kernel starting and the spontaneous reboot is so fast I can't tell 
how far the kernel got during the boot.

When the machine comes back up (from the reboot) it fails many self tests 
during boot (memory, cache memory, CPU, floppy). The machine has been running 
RH 7.3 for about a year without problems. Memtest86 reports no problems over a 
24 hour run.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create boot disk from /images/bootdisk.img on CD #1.
2. Boot machine.

Actual Results:  Machine reboots immediately after loading kernel.

Expected Results:  Expect kernel to start.

Additional info:

I tried passing mem=24M, mem=32M and noapic to the kernel without success. The 
machine has 32M memory (Vectra XU 5/90).
Comment 1 John William 2003-09-25 23:30:18 EDT
Tried various combinations of "apm=off" and "nomce" with "mem=" and "noapic" 
without luck. Will try to get serial console working to pin down how far the 
kernel gets before rebooting.
Comment 2 John William 2003-09-26 20:27:31 EDT
Created attachment 94773 [details]
Boot log from serial console

Boot log captured from serial console. Machine reboots after printing the last
line - no delay.
Comment 3 John William 2003-10-18 11:13:26 EDT
I have recently discovered that adding "pci=conf1" or "pci=conf2" to the kernel 
command line will allow the machine to boot normally. Maybe some driver is not 
honoring the PCI detection method? This is strange as the boot data shows the 
kernel is using type 1 configuration.
Comment 4 Bugzilla owner 2004-09-30 11:41:33 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.