Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1056267 - there was an error playing video from the webcam (Logitech C170)
Summary: there was an error playing video from the webcam (Logitech C170)
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: cheese
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 20:17 UTC by Stefano Costa
Modified: 2015-06-29 14:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-06-29 14:38:27 UTC
Type: Bug


Attachments (Terms of Use)

Description Stefano Costa 2014-01-21 20:17:12 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. plug webcam
2. start cheese
3. get error

Actual results:

[steko@ogma ~]$ LC_ALL=C cheese
LC_ALL=C cheese 

(cheese:3438): GLib-GObject-WARNING **: value "5.000000" of type 'gdouble' is invalid or out of range for property 'delaytime' of type 'gdouble'
libv4l2: error got 4 consecutive frame decode errors, last error: v4l-convert: libjpeg error: End Of Image

(cheese:3438): cheese-WARNING **: Internal data flow error.: gstbasesrc.c(2865): gst_base_src_loop (): /GstCameraBin:camerabin/GstWrapperCameraBinSrc:camera_source/GstBin:bin34/GstV4l2Src:video_source:
streaming task paused, reason error (-5)




Additional info: works perfectly with WebRTC apps

Comment 1 Dale Raby 2014-05-06 14:10:10 UTC
I had this exact problem, by that I mean, the same error messages.  I tried installing guvcview, which also did not work, but I stumbled into a fix:

Before starting Cheese, start guvcview, then close guvcview and restart Cheese.  Voila!  Everything works.  I'm guessing that something that is supposed to be started by Cheese is not started until attempting to run guvcview, which starts whatever is missing.

I am not an IT tech, but hopefully somebody who IS one will be able to get some useful intel from this.

I guess these little things make life more interesting.

Comment 2 slip 2014-05-22 01:19:32 UTC
Fedora 20:
AMD Arch:
"guvcview: command not found"

Comment 3 Leif Madsen 2015-02-06 19:02:54 UTC
For @slip:

$ sudo yum whatprovides */guvcview
Loaded plugins: langpacks
guvcview-1.7.3-4.fc21.x86_64 : GTK+ UVC Viewer and Capturer
Repo        : rpmfusion-free
Matched from:
Filename    : /usr/share/doc/guvcview
Filename    : /usr/bin/guvcview
Filename    : /usr/share/pixmaps/guvcview



guvcview-1.7.3-4.fc21.x86_64 : GTK+ UVC Viewer and Capturer
Repo        : @rpmfusion-free
Matched from:
Filename    : /usr/bin/guvcview

Comment 4 Fedora End Of Life 2015-05-29 10:36:37 UTC
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 5 Fedora End Of Life 2015-06-29 14:38:27 UTC
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.