Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1056272 - cpuscaling test hang waiting for work processes
Summary: cpuscaling test hang waiting for work processes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Retired
Component: Test Suite (tests)
Version: 1.6.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: William Gomeringer
URL:
Whiteboard:
Depends On: 1056269
Blocks: 1052387
TreeView+ depends on / blocked
 
Reported: 2014-01-21 20:39 UTC by Greg Nichols
Modified: 2014-05-21 19:20 UTC (History)
4 users (show)

Fixed In Version: hwcert-client 1.6.5.2-20140226
Doc Type: Bug Fix
Doc Text:
Clone Of: 1056269
Environment:
Last Closed: 2014-05-21 19:20:08 UTC


Attachments (Terms of Use)
cpuscaling patch fixing work process return code logic (1.02 KB, patch)
2014-01-21 20:43 UTC, Greg Nichols
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0532 0 normal SHIPPED_LIVE hwcert-client-1.6.5 bug fix and enhancement update 2014-05-21 23:18:09 UTC

Description Greg Nichols 2014-01-21 20:39:18 UTC
+++ This bug was initially created as a clone of Bug #1056269 +++

Description of problem:

The cpuscaling test hangs waiting for work processes:

[...]
Running load test for package 0
starting process for cpu 0
using work process: ./aperf  0
starting process for cpu 1
using work process: ./aperf  1
starting process for cpu 2
using work process: ./aperf  2
starting process for cpu 3
using work process: ./aperf  3
starting process for cpu 4
using work process: ./aperf  4
starting process for cpu 5
using work process: ./aperf  5
starting process for cpu 6
using work process: ./aperf  6
starting process for cpu 7
using work process: ./aperf  7
starting process for cpu 8
using work process: ./aperf  8
starting process for cpu 9
using work process: ./aperf  9
starting process for cpu 10
using work process: ./aperf  10
starting process for cpu 11
using work process: ./aperf  11
waiting for load processes...




Version-Release number of selected component (if applicable):

hwcert-1.7.0-20140120

How reproducible:

every time.

--- Additional comment from Greg Nichols on 2014-01-21 15:36:18 EST ---

Comment 1 Greg Nichols 2014-01-21 20:43:33 UTC
Created attachment 853439 [details]
cpuscaling patch fixing work process return code logic

Comment 6 errata-xmlrpc 2014-05-21 19:20:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0532.html


Note You need to log in before you can comment on or make changes to this bug.