Bug 1056289 - Cannot rebuild ibacm on RHEL7, %{_unitdir} undefined
Summary: Cannot rebuild ibacm on RHEL7, %{_unitdir} undefined
Keywords:
Status: CLOSED DUPLICATE of bug 1056590
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ibacm
Version: 7.0
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Doug Ledford
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-21 21:58 UTC by Pat Riehecky
Modified: 2014-01-28 15:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 22:25:14 UTC
Target Upstream Version:


Attachments (Terms of Use)
mock config for replication (1.29 KB, text/plain)
2014-01-21 21:58 UTC, Pat Riehecky
no flags Details

Description Pat Riehecky 2014-01-21 21:58:52 UTC
Created attachment 853486 [details]
mock config for replication

Description of problem: ibacm cannot be rebuilt on RHEL7.  The %{_unitdir} is utilized by the spec file but the package that defines this macro is not listed in BuildRequires:

BuildRequires: systemd

Version-Release number of selected component (if applicable):ibacm-1.0.8-0.git7a3adb7.1.el7.src.rpm


How reproducible:100%


Steps to Reproduce:
1.install minimal buildroot and listed BuildRequires:
2.rpmbuild --rebuild ibacm-1.0.8-0.git7a3adb7.1.el7.src.rpm
3.

Actual results:
<snip>
+ cp -pr README /builddir/build/BUILDROOT/ibacm-1.0.8-0.git7a3adb7.1.el7.i386/usr/share/doc/ibacm-1.0.8
+ exit 0
RPM build errors:
    File must begin with "/": %{_unitdir}/ibacm.service
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
</snip>

Expected results: Can build without issue


Additional info:
https://fedoraproject.org/wiki/Packaging:Systemd?rd=Packaging:Guidelines:Systemd#Packaging

Comment 2 Doug Ledford 2014-01-23 22:25:14 UTC

*** This bug has been marked as a duplicate of bug 1056590 ***


Note You need to log in before you can comment on or make changes to this bug.