Bug 1056317 - [GTK3] Door hanger ui does not have a border
Summary: [GTK3] Door hanger ui does not have a border
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 19
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-22 00:30 UTC by Kevin Brosnan :kbrosnan
Modified: 2014-02-28 19:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1070741 (view as bug list)
Environment:
Last Closed: 2014-02-28 19:05:43 UTC
Type: Bug


Attachments (Terms of Use)
Borderless door hanger UI (24.67 KB, image/png)
2014-01-22 00:30 UTC, Kevin Brosnan :kbrosnan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Mozilla Foundation 978172 0 None None None Never

Description Kevin Brosnan :kbrosnan 2014-01-22 00:30:58 UTC
Created attachment 853526 [details]
Borderless door hanger UI

Description of problem: Door hanger ui does not have a border


Version-Release number of selected component (if applicable): 29a1 (Jan-17)


How reproducible: Always


Steps to Reproduce:
1. Open about:home
2. Click on the nightly box in the address bar

Actual results: Door hanger does not have a border


Expected results: Door hanger has a border


Additional info: HTTPS info, geolocation, mixed content blocking, blocked, missing, or disabled plugins are several other ways to produce a door hanger UI in Firefox.

Comment 1 Martin Stransky 2014-02-24 12:27:23 UTC
Yes, I can reproduce it. Also "$export GTK_DEBUG=all; firefox-gtk3" shows such issue and unpainted areas.

Comment 2 Martin Stransky 2014-02-27 13:56:28 UTC
The wrong background color here is sButtonInnerDarkBorder.

Comment 3 Martin Stransky 2014-02-28 16:26:54 UTC
Looks like we have to pick up a different element to get those colors, because gtk3 theme has transparent border colors.

Comment 4 Martin Stransky 2014-02-28 18:29:59 UTC
Well, the doorhanger background is rendered by sMozWindowBackground so I guess we can use it for the border too.

Comment 5 Martin Stransky 2014-02-28 19:05:43 UTC
Movig upstrem - https://bugzilla.mozilla.org/show_bug.cgi?id=978172


Note You need to log in before you can comment on or make changes to this bug.