Bug 105642 - network configuration in anaconda doesn't allow interfaces without an IP
network configuration in anaconda doesn't allow interfaces without an IP
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-26 03:58 EDT by Pekka Pietikäinen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-04 16:38:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2003-09-26 03:58:18 EDT
Description of problem:

Anaconda requires that ethernet cards are either given an IP or set to use DHCP.
In some configurations like PPPoE you don't actually want to give the NIC any
address. redhat-config-network allows this.

Not sure what the best way of fixing this would be, one possibility would be to
move network configuration into firstboot, which could just use
redhat-config-network, but this has issues as well. Or maybe allow a no IP
setting (possibly warning that it usually doesn't make sense), possibly
explaining that
to configure PPPoE you need to use redhat-config-network after the install is done.

I assume PPPoE support in the installer is out of the question so I'm not even
suggesting that :-)
Comment 1 Michael Fulbright 2003-09-26 16:34:42 EDT
This is going to be something we need to ask about in firstboot as you guessed.
Comment 2 Brent Fox 2004-01-08 15:02:10 EST
We can't move all network configuration into firstboot because
anaconda frequently needs network information in order to do network
installs.  
Comment 3 Brent Fox 2004-03-04 16:38:03 EST
I think the best solution is for people who need to configure PPPoE to
just run redhat-config-network after the installation.
Comment 4 Pekka Pietikäinen 2004-03-04 16:56:32 EST
Fair enough, as long as there's a way to skip that dialog (and end up
with no network at all) vs. the user having to setup a configuration
he doesn't want in anaconda just to get through the install. I believe
this is the case, but best to be sure...

Note You need to log in before you can comment on or make changes to this bug.