This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 105653 - ascii graphics of newt utils is corrupted in single user mode
ascii graphics of newt utils is corrupted in single user mode
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sysvinit (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 127179 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2003-09-26 06:20 EDT by Jussi Torhonen
Modified: 2014-03-16 22:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.85-39
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-27 11:42:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jussi Torhonen 2003-09-26 06:20:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
Using Fedora test2. During the install I selected LDAP as a network login
service. Due local networking problems the system did not see thet LDAP server
at all so I could not login into the system. 

Rebooted the system uptio single user mode to reconfigure authentication with
authconfig utility. authconfig launches and works fine, but the ascii graphics
was terrible. Some charset problems or whatever. Ascii lines were corrupted and
some weird color, blinking text fields and so on was seen. 

But authconfig worked actually and I got the system reconfigured to authenticate
locally. After booting upto runlevel 5 I was able to log in normally.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot the system into single user mode (add 'single' to grub cmdline)
2. anter command 'authconfig'
3. see the mess

    

Additional info:

authconfig looks normal if you launch it in a X11 terminal, or if you open a
text mode virtual screen (crtl+alt+f5), login and launch it there. It's the
single user mode which corrupts ascii graphics of this utility. Perhaps the same
happens in single user mode for other text mode utils as well? Haven't tried that.
Comment 1 Bill Nottingham 2003-09-26 15:52:33 EDT
What's your /etc/sysconfig/i18n?
Comment 2 Jussi Torhonen 2003-09-27 10:26:16 EDT
Hi, Bill

The machine is in my office. I'll tell about i18n on early Monday morning EEST.

Used default English localization and installed Finnish as an auxiliary locale.
Kbd layout was Finnish(latin1) alias fi-latin1. But I'll tell the exact content
of i18n later.

Jussi
Comment 3 Jussi Torhonen 2003-09-29 01:03:54 EDT
Here's my /etc/sysconfig/i18n:

LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en:fi_FI.UTF-8:fi_FI:fi"
SYSFONT="latarcyrheb-sun16"

Jussi
Comment 4 Tomas Mraz 2004-12-13 13:42:24 EST
This happens (to all utils using newt or ncurses) because in the
single user mode the LANG env variable is not set.

if you run it using:
# LANG="en_US.UTF-8" authconfig

it works fine.
Comment 5 Bill Nottingham 2005-04-15 14:04:40 EDT
Switching component to where this would have to be fixed.
Comment 6 Bill Nottingham 2005-04-26 14:07:02 EDT
*** Bug 127179 has been marked as a duplicate of this bug. ***
Comment 7 Bill Nottingham 2005-04-27 11:42:03 EDT
Added in SysVinit-2.85-39; the single user shell is now a login shell.
Comment 8 David Lawrence 2007-06-21 22:18:31 EDT
Package name is now sysvinit in latest Fedora.

Note You need to log in before you can comment on or make changes to this bug.