Bug 10567 - Upgrade RH6.1 => RH6.2 overwrites /etc/ppp/ip-up.local
Summary: Upgrade RH6.1 => RH6.2 overwrites /etc/ppp/ip-up.local
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: isdn-config   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Florian La Roche
QA Contact:
URL:
Whiteboard:
Keywords:
: 10563 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-03 21:38 UTC by Gustav Schaffter
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-16 08:14:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gustav Schaffter 2000-04-03 21:38:51 UTC
In RH6.0 and RH6.1 there was no /etc/ppp/ip-up.local provided. In the
/etc/ppp/ip-up script, there is a test to see if the file
/etc/ppp/ip-up.local exists and if it's executable. If so the file is
executed.

In the ip-up file there is a comment stating (and I quote):
"This file should not be modified -- make local changes to
/etc/ppp/ip-up.local instead"

The upgrade from RH6.1 to RH6.2 overwrote my ip-up.local with a script
file containing code to save resolv.conf if the interface is ippp
(ISDN?).

It also created an unexpected file /etc/ppp/ip-down.local

Regards
Gustav

Comment 1 Bill Nottingham 2000-04-03 22:04:59 UTC
*** Bug 10563 has been marked as a duplicate of this bug. ***

Comment 2 Gustav Schaffter 2000-04-04 07:53:59 UTC
Hi,

I had the following (very reasonable) comment from Gordon Messmer
(yinyang@eburg.com)

+++++++++++++++++++++++++
Since you've already submitted a bug report, perhaps you can modify it
with the suggestion that the isdn-config package create the files:
/etc/ppp/ip-down.isdn
/etc/ppp/ip-up.isdn
rather than
/etc/ppp/ip-down.local
/etc/ppp/ip-up.local

then, modifiy the ip-up and ip-down scripts to test for the presence of
those two files.  they already test for ip-up.local and ip-up.heart (and
of course, ip-down.local and ip-down.heart).  Adding another check would
be simple.

Or... they could get jiggy and create /etc/ppp/ip-up.d/ and run all of
the scripts in there!!  :)
+++++++++++++++++++++++++

Makes sense, IMO.
Gustav

Comment 3 Florian La Roche 2000-05-16 08:14:59 UTC
resolved in newest package within the rawhide release


Note You need to log in before you can comment on or make changes to this bug.