Bug 105674 - /etc/init.d/named restart: too fast restart after stop
/etc/init.d/named restart: too fast restart after stop
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-26 10:27 EDT by Jan Demey
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 16:02:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Demey 2003-09-26 10:27:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The restart option of the /etc/init.d/named script executes stop and then start 
(immediately after it).
The named isn't starting if there is still a 'named-process', which is the case 
in the first few seconds after the stop command has been given in the case of a 
heavy loaded DNS server. Because of that there is a risk that the restart 
doesn't really do a restart and returns code 1.
I think the solution is to alter the script like this:
restart() {
        stop
        sleep 3
        start
}

Version-Release number of selected component (if applicable):
bind-9.2.1-9

How reproducible:
Sometimes

Steps to Reproduce:
1. execute /etc/named/restart on a highly loaded DNS server
2. 
3.
    

Actual Results:  Output: named already running
Return code 1, and named doesn't start

Expected Results:  restart of named

Additional info:

This problem can be severe in a case where you have 2 DNS servers, with a 
heartbeat configuration so that the 2nd DNS server takes over when the first 
goes down. As this 2nd takes over the IP address of the first, we configured 
heartbeat to issue a /etc/init.d/named restart, the named doesn't start and ... 
no DNS!
Comment 1 Daniel Walsh 2003-09-29 16:02:55 EDT
THe latest bind script currently has this fix.  (Sleep 2)

Note You need to log in before you can comment on or make changes to this bug.