Bug 105695 - single does not work in first boot after install
single does not work in first boot after install
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-09-26 12:35 EDT by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-09-28 14:17:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-09-26 12:35:33 EDT
Description of problem:

I did a fresh install of Fedora Core.  When I booted, I edited the grub kernel
line to add "nogui single" and then booted.  As I wathced the boot process, I
could see the message for switching to runlevel 5 and booting continuing.  I
immediately did a ctl-alt-delete to reboot (I did not want the system starting
before I did some things).  I then again edited the grub kernel line to add
"nogui  single" and again booted.  This time (and every time after that I
specify single) the system went into single user mode.

How reproducible:
Yes, but it is a real pain -- it seems to take a fresh install and the first
boot after install to have the problem.
Comment 1 Bill Nottingham 2003-09-26 14:59:19 EDT
There's nothing specific about the first boot that should cause it to ignore
command line parameters - firstboot runs well after it chooses a default
runlevel. Perhaps grub is screwy?
Comment 2 Jeremy Katz 2003-09-26 15:05:00 EDT
Did you maybe hit esc instead of enter after adding command line arguments?  
Comment 3 Gene Czarcinski 2003-09-26 15:36:32 EDT
I don't feel like screwing up the system that I first tested on so I will be
trying this on a laptop I want to put fedora on.  It will not be exactly the
same but I believe it will have the problem.

I actual saw this problem some time ago (either the RHL 8 or RHL 9 beta cycle).
 At that time, it seemed to be ignoring "single" every time and going right into
firstboot.  This time when I did the ctl-alt-delete and reboot and single
"worked" the second time is when I got interested.

Any specific information I can get you to respond to NEEDINFO?

I would not be pushing this except that I believe there is a real need sometimes
to get into single user mode the very first time you boot the installed system.

One of the tests I will run is to let the boot process which should have gone
into single user mode but instead when into runlevel 5 and look at /proc/cmdline.
Comment 4 Bill Nottingham 2003-09-26 15:43:46 EDT
The code that determines what run level you go into and whether to start rhgb is
100% independent of firstboot, and does not care how many times you boot the
system. Hence, this sounds like a 'can't happen' thing at first glance.
Comment 5 Gene Czarcinski 2003-09-28 14:17:34 EDT
Oops ... pilot error!

OK, I would swear that I had seen this "problem" with an earlier release but
that was with the same "pilot" so I may have done something stupid like spelled
"single" as "singel" or whatever and never noticed.

I ran three separate fresh installs and inital boots with "nogui single"
specified  -- one on real hardware workstation, one on a laptop and one as a
vmware guest (where I first "noticed" the "problem") ... they all worked this
time so I must assume a pilot error.

I did not mention vmware initially because of the aversion of Red Hat folks to
look at vmware problems and I just "knew" I had seen the problem on real
hardware.  For vmware, I need to get in and fixup the XFree86
support/configuration so that firstboot, etc. work OK right from the start.

Anyway, this bug report is now closed.

Note You need to log in before you can comment on or make changes to this bug.