Bug 105699 - Mozilla process bloats to hundreds of megabytes in size
Mozilla process bloats to hundreds of megabytes in size
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mozilla (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-26 13:02 EDT by John Gotts
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 03:59:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Gotts 2003-09-26 13:02:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I leave mozilla running all the time, because I do things like read portions of
mailing list archives, go do something else for a day or two, and go back to
what I was doing.  When I start mozilla, I load the following URL's, which stay
loaded all the time:

https://my.secure.yahoo.com/
http://slashdot.org/
http://freshmeat.net/daily/YYYY/MM/DD/
http://plastic.com/
http://memepool.com/
http://metafilter.com/
http://fark.com/
http://forums.gardenweb.com/forums/cacti/
http://www.redhat.com/archives/shrike-list/YYYY-Month/thread.html
http://www.redhat.com/archives/psyche-list/YYYY-Month/thread.html
http://www.redhat.com/archives/valhalla-list/YYYY-Month/thread.html

Typically all but one of those sites would be minimized and any other URL's
would be loaded in new windows which would then be closed.

The problem is that after several days, the mozilla process grows to several
hundred megabytes in size.  I can tell when it's gotten large because there is a
one second or longer delay between clicking above or below the scrollbar and
seeing the current page move.  My computer is an AMD XP 2600+ with 512 MB of
system memory, so this should never occur!

I do not have Java installed and these web sites use little, if any, Flash.  My
memory cache is set to 4096 KB.

Version-Release number of selected component (if applicable):
1.2.1-26

How reproducible:
Always

Steps to Reproduce:
1. Use mozilla for a few days.

Actual Results:  [jgotts@linux7 jgotts]$ free
             total       used       free     shared    buffers     cached
Mem:        513868     503640      10228          0     168624     110548
-/+ buffers/cache:     224468     289400
Swap:      1052248     464284     587964
[jgotts@linux7 jgotts]$ ps auxww | grep mozilla
jgotts   11508  0.7 17.1 201904 87992 ?      S    Sep23  31:16
/usr/lib/mozilla-1.2.1/mozilla-bin
(File->Exit)
[jgotts@linux7 jgotts]$ free
             total       used       free     shared    buffers     cached
Mem:        513868     371004     142864          0     165748     100260
-/+ buffers/cache:     104996     408872
Swap:      1052248     163856     888392

As you can see, in only three days mozilla managed to consume a total of 552,536
KB of memory.  I have to kill mozilla every few days or else my machine becomes
unusable.  I should also note that I did *not* experience this problem with Red
Hat Linux 7.3.

Expected Results:  The mozilla process should much less memory.

Additional info:
Comment 1 Christopher Blizzard 2003-09-29 17:11:47 EDT
Yeah, I suspect we leak some memory.  Have you had better luck with the 1.4 on
the new fedora beta?  Should be better than 1.2.1.
Comment 2 Josko Plazonic 2003-10-30 23:34:49 EST
I have to sort of agree with this report.  I've seen this problem from stock
mozilla on RH9 to any rebuilt mozilla from rawhide after that (built by myself,
running now what is essentially 1.4.1-15, same patches different packaging).  It
usually takes me only a few hours of browsing and reading email to trigger it. 
It becomes unbearably slow. It may have to do with memory but in my case it
"only" reaches 60-70MBs which is not that much for mozilla (just restarted it
now and it is 41MB).  I suspect it is either linux/gtk2 specific or at least
easier to trigger there as I've never experienced the same behaviour in windows.

Note that as soon as you switch to some other applications, mozilla stops taking
CPU time and machine is back to normal (until you go back to it).

I'll try to attach gdb to it next time it happens.  Any other suggestions?
Comment 3 Christopher Blizzard 2003-11-03 13:29:20 EST
If you're talking about a sudden change where mozilla churns and takes
forever to draw, that's a bug down in Xft's memory management and has
been fixed in recent releases.  Mozilla probably has quite a few other
random memory leaks, but I haven't seen specific fixes to them.
Comment 4 John Gotts 2003-11-04 01:49:58 EST
That might be the bug I was experiencing, except that I'm more patient
than Josko and wait till mozilla bloats to several hundred megabytes.
 I might remove the stock Red Hat Linux 9 mozilla and try something
more recent.  What I usually do for non-crashing bugs is wait until
the next release of Red Hat Linux, but since there will never be
another release I better try a different strategy.
Comment 5 Josko Plazonic 2003-11-04 18:33:20 EST
Are you saying there is a patch somewhere for XFree86 that's going to
fix this?  I'd be forever grateful if you maybe remember where you saw
the report and the patch.  If you are saying there is a patch for
mozilla - it's not there in mozilla-1.4.1-15...  In any case, I (and a
number of my users) will be happy to test any fixes.

In the meantime, I am fetching the rawhide XFree86 - will try to
compile or backport all xft related stuff.  Thanks for the clue.
Comment 6 Christopher Blizzard 2003-11-05 09:10:56 EST
I'm talking about a patch for the sudden slowdown problem, nothing
more.  That's a fix that's in Xft somewhere.  Since I don't own the
package I'm not sure when it was included.  However, I do know that it
was included in FC1.
Comment 7 John Gotts 2003-11-05 14:51:55 EST
Ouch, just had the mozilla process exceed one gigabyte of memory in
under three days.

At least my I/O subsystem is getting a good workout!

I am going to try versions in Fedora or on the mozilla FTP site and
report back whether they have the same problem.
Comment 8 Warren Togami 2005-04-25 03:59:45 EDT
Too old and not enough information to diagnose.
Comment 9 John Gotts 2005-04-25 16:53:34 EDT
Try asking for more information.

Note You need to log in before you can comment on or make changes to this bug.