Bug 1057178 - Migration on the ppc64 platform
Summary: Migration on the ppc64 platform
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: ppc64
OS: Linux
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: bugs@ovirt.org
QA Contact: bugs@ovirt.org
URL:
Whiteboard: ppc
Keywords:
: 1151516 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-23 15:18 UTC by Vitor de Lima
Modified: 2014-10-29 21:37 UTC (History)
10 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-10-17 12:36:10 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21522 master MERGED core, engine: Avoid migration in ppc64 Never
oVirt gerrit 21523 None MERGED userportal, webadmin: Prevent migration on the frontend Never
oVirt gerrit 21643 master MERGED core, engine, restapi: Proper default migration policies for ppc64 Never
oVirt gerrit 21644 master MERGED core, engine: Disable Migrate On Error on ppc64 clusters Never
oVirt gerrit 23238 None MERGED core, engine, webadmin: Retrieve Capabilities for each Architecture Never
oVirt gerrit 25045 ovirt-engine-3.4 ABANDONED core, engine, webadmin: Retrieve Capabilities for each Architecture Never
oVirt gerrit 25046 ovirt-engine-3.4 ABANDONED core, engine: Avoid migration in ppc64 Never
oVirt gerrit 25048 ovirt-engine-3.4 ABANDONED userportal, webadmin: Prevent migration on the frontend Never
oVirt gerrit 25052 ovirt-engine-3.4 ABANDONED core, engine: Disable Migrate On Error on ppc64 clusters Never
oVirt gerrit 25053 ovirt-engine-3.4 ABANDONED core, engine, restapi: Proper default migration policies for ppc64 Never
oVirt gerrit 34618 ovirt-engine-3.5 MERGED core, engine, restapi: Proper default migration policies for ppc64 Never

Description Vitor de Lima 2014-01-23 15:18:50 UTC
Description of problem:
Migration does not work on the ppc64 platform, this is a limitation of the current versions of QEMU/KVM.

Version-Release number of selected component (if applicable):
3.4 master branch (SHA-1 25af414ca841a411b999a8d14edb4b558f5a7295)

How reproducible:
Always

Steps to Reproduce:
1. Properly configure a Data Center, Cluster, Hosts and VMs for the ppc64 architecture.
2. Select a running VM and click on "Migrate"

Actual results:
The migration is never completed.

Expected results:
The VM is migrated to another host.

Additional info:
This feature should be blocked until QEMU/KVM for ppc64 supports it.

Comment 1 Itamar Heim 2014-01-26 08:11:09 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:20:07 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Sandro Bonazzola 2014-05-08 13:55:46 UTC
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.

Comment 4 Itamar Heim 2014-06-13 01:53:20 UTC
isn't this supported on power8?

Comment 5 Vitor de Lima 2014-08-22 16:25:10 UTC
PowerKVM (the hypervisor distro from IBM) supports this, the QEMU shipped with Fedora 20 does not.

Comment 6 Michal Skrivanek 2014-10-10 18:31:06 UTC
*** Bug 1151516 has been marked as a duplicate of this bug. ***

Comment 7 Sandro Bonazzola 2014-10-17 12:36:10 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.