Bug 105735 - Cosmetic Metacity bug
Cosmetic Metacity bug
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-26 16:59 EDT by Dan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-04 01:13:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan 2003-09-26 16:59:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
using Mozilla to browse the web I like to have the window maximized.  When I
start Mozilla it starts as maximized the way I like it but it does not maximize
correctly.  On the top right corner to the right of the close button there is a
space of 10 pixcils inbetween the edge of the screen and the edge of the right
most part of the title bar.  This also includes the right edge of the window as
well it may not be 10 pixcils it is 5 pixcils wide.  This space is the same
color of the controls.  This just happens to look very ugly and the only way to
return the maximize to the way it is supposed to be you have to unmaximize then
remaximize.  I do have a screenshot available please email me
daniel.nelson@comcast.net

Version-Release number of selected component (if applicable):
metacity-2.5.3-3

How reproducible:
Always

Steps to Reproduce:
1.start Mozilla for the first time it is in a small window
2.maximize Mozilla then close Mozilla
3.start Mozilla again this time it starts maximized with this space on the right
side
4.from this moment on every time that Mozilla starts it does this
and problably other programs that start maximized
    

Actual Results:  it just looks very unprofessional and retarded again I have a
screenshot available just email me at daniel.nelson@comcast.net (my main email)

Expected Results:  what should be happing is that the window should be maximized
all the way to the edge without 10 pixcils of space on the title bar.

Additional info:

I don't know if anybody else sees this but it happens every time for me.  Like I
said screenshot is available just email me asking for it, please use my main
email addy daniel.nelson@comcast.net
Comment 1 Havoc Pennington 2003-10-03 16:46:07 EDT
Is this fixed in metacity 2.6.2?
Comment 2 Havoc Pennington 2003-10-04 01:13:41 EDT
(if not fixed in 2.6.2 please reopen the report)
Comment 3 Lewi 2003-10-10 21:30:53 EDT
I update metacity to metacity-2.6.2-1.src.rpm from rawhide
and rebuild in fedora test2, 
it's only solve in gtk2 apps, or except gtk1 apps

the problem is still exist in gtk1 apps, 
I have been trying with mozilla firebird 0.6 d/w from mozilla.org
that compiled using gtk1,

step to reproduce is exactly same
windows will have some space in top right corner of the window

Note You need to log in before you can comment on or make changes to this bug.