Bug 10574 - database corruption
Summary: database corruption
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-04 04:49 UTC by dm
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-06 19:21:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description dm 2000-04-04 04:49:46 UTC
OpenLdap is compiled with  berkeley db2 version lower
than 2.7.5. This cause database corruption

Comment 1 Nalin Dahyabhai 2000-04-05 16:40:59 UTC
OpenLDAP is built using the version of DB 2 bundled with glibc.  What specific
problems are you having?

Comment 2 dm 2000-04-06 03:56:59 UTC
Problem is that sooner or later (3,4 days
or even weeks) after openldap restart database is corrupted.
Looks like problem is in database.Openldap faq says
that it need db2 >= 2.7.5. Now I compile openldap 1.2.9-4.srpm
with berkeley db2 2.7.7 and run it about week. After restart all
is OK. But this is not complete  test :(

Comment 3 Nalin Dahyabhai 2000-04-06 19:21:59 UTC
Version 1.2.9 from Raw Hide (ftp://ftp.redhat.com/pub/rawhide/i386/RedHat/RPMS/)
or 6.2 may already solve this problem.  I'm changing the component to glibc,
which is where the bundled copy of Berkeley DB is in, so that's where a fix
would need to be made.

Comment 4 Nalin Dahyabhai 2000-09-12 18:53:39 UTC
To avoid this problem, we're switching to gdbm for future builds of OpenLDAP. 
Migration will be messy, though, as it requires a manual ldbmcat before the
upgrade and an ldif2ldbm afterwards.


Note You need to log in before you can comment on or make changes to this bug.