Bug 1057489 (CVE-2013-6487) - CVE-2013-6487 pidgin: Heap-based buffer overflow in Gadu-Gadu protocol plugin
Summary: CVE-2013-6487 pidgin: Heap-based buffer overflow in Gadu-Gadu protocol plugin
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2013-6487
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1058238 1058239 1058240 1058242 1058243 1059049 1060921 1060922
Blocks: 1054257
TreeView+ depends on / blocked
 
Reported: 2014-01-24 08:53 UTC by Huzaifa S. Sidhpurwala
Modified: 2021-02-17 06:56 UTC (History)
11 users (show)

Fixed In Version: pidgin 2.10.8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 19:38:37 UTC


Attachments (Terms of Use)
Local copy of patch (1.01 KB, patch)
2014-01-27 06:17 UTC, Huzaifa S. Sidhpurwala
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2014:0139 0 normal SHIPPED_LIVE Moderate: pidgin security update 2014-02-05 22:42:24 UTC

Description Huzaifa S. Sidhpurwala 2014-01-24 08:53:51 UTC
A Heap-based buffer overflow was found in the way Gadu-Gadu protocol plugin of pidgin. A malicious server or man-in-the-middle could send a large value for Content-Length and cause an integer overflow which could lead to a buffer overflow. This could cause pidgin to crash or possibly execute arbitrary code with the permissions of the user running pidgin. 

Acknowledgements:

Red Hat would like to thank the Pidgin project for reporting this issue. Upstream acknowledges Yves Younan and Ryan Pentney of Sourcefire VRT as the original reporters of this issue.

Comment 1 Huzaifa S. Sidhpurwala 2014-01-27 06:17:32 UTC
Created attachment 855928 [details]
Local copy of patch

Comment 4 Vincent Danen 2014-01-28 20:47:10 UTC
External References:

http://pidgin.im/news/security/?id=82

Comment 5 Huzaifa S. Sidhpurwala 2014-01-29 04:26:00 UTC
Created pidgin tracking bugs for this issue:

Affects: fedora-all [bug 1059049]

Comment 6 Vincent Danen 2014-02-03 22:49:58 UTC
This also affects libgadu.

Comment 7 Vincent Danen 2014-02-03 22:50:32 UTC
Created libgadu tracking bugs for this issue:

Affects: fedora-all [bug 1060921]

Comment 9 errata-xmlrpc 2014-02-05 17:44:56 UTC
This issue has been addressed in following products:

  Red Hat Enterprise Linux 5
  Red Hat Enterprise Linux 6

Via RHSA-2014:0139 https://rhn.redhat.com/errata/RHSA-2014-0139.html

Comment 10 Fedora Update System 2014-02-06 03:50:07 UTC
pidgin-2.10.9-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2014-02-14 07:59:43 UTC
pidgin-2.10.9-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2014-02-14 08:04:02 UTC
libgadu-1.12.0-0.3.rc2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2014-02-22 18:20:29 UTC
libgadu-1.12.0-0.3.rc2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.