Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Created attachment 854873[details]
win8.1-64-netkvm-hck-file
Description of problem:
win8.1-64 and win2012R2 guest always hang when run the four hck jobs:
DF - Sleep with IO During (Certification)
DF - Sleep and PNP (disable and enable) with IO Before and After (Certification)
DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)
NDISTest 6.5 - [2 Machine] - MPE_Ethernet.xml
Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-30.el7.x86_64
kernel-3.10.0-64.el7.x86_64
seabios-1.7.2.2-7.el7.x86_64
virtio-win-prewhql-1.6.7-2
How reproducible:
100%
Steps to Reproduce:
1.boot two guests with:
nic1:
/usr/libexec/qemu-kvm -m 6G -M pc -smp 8,cores=8 -cpu SandyBridge,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic -usb -device usb-tablet -drive file=win2012-R2-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -uuid 5044b1e3-9c86-438e-87c1-8aba752e7430 -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=a11,path=/tmp/monitor-win2k12R2-netkvm-1.6.7-2,server,nowait -mon chardev=a11,mode=readline -vnc :5 -vga cirrus -chardev socket,id=channel0,path=/tmp/tt,server,nowait -name win2k12R2-netkvm-1.6.7-2-nic1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -cdrom /usr/share/virtio-win/virtio-win.iso -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:23:a8:63:62:61,id=net0 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup1,downscript=no -device e1000,netdev=hostnet1,mac=00:23:a8:23:22:21,id=net1
nic2:
/usr/libexec/qemu-kvm -m 2G -M pc -smp 2,cores=2 -cpu SandyBridge,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic -usb -device usb-tablet -drive file=win2012-R2-nic2.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -uuid 3137012a-99ac-4355-a79b-f16fc2b3f3a3 -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=a11,path=/tmp/monitor-win2k12R2-netkvm-1.6.7-2,server,nowait -mon chardev=a11,mode=readline -vnc :6 -vga cirrus -chardev socket,id=channel0,path=/tmp/tt,server,nowait -name win2k12R2-netkvm-1.6.7-2-nic2 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -cdrom /usr/share/virtio-win/virtio-win.iso -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:23:a8:64:75:86 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup1,downscript=no -device e1000,netdev=hostnet1,mac=00:23:a8:65:50:29
2.submit jobs in hck2.1
Actual results:
guest hang while running the four jobs above,reboot guest and job failed
Expected results:
no hang,jobs can pass
Additional info:
1.jobs can pass if S4 is disabled in qemu command;
2.NMICrashDump is enabled in guests,but cannot generate any dump file when set nmi in qemu monitor,guest has no response to nmi command.
(In reply to Mike Cao from comment #3)
> I remember lijin said guest hang even we use trl8139 as the message
> device,lijin, can you confirm?
yes,when change e1000 to rtl8139,guest still hang.
The same issue could also be reproduced on win2012 and win8-64 guest.
win2012 platform,
1.NDISTest 6.5 - [2 Machine] - MPE_Ethernet.xml
2.DF - Sleep with IO During (Certification)
3.DF - Sleep and PNP (disable and enable) with IO Before and After (Certification)
4.DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)
5.NDISTest 6.0 - [2 Machine] - 2c_Mini6RSSSendRecv (Multi-Group Win8+)
win8-64 platform
1.PM_PowerStateTransition
2.NDISTest 6.5 - [2 Machine] - MPE_Ethernet.xml
win2012R2 hit the same issue again when run serial hck jobs:
1.DF - Sleep with IO During (Certification)
2.DF - Sleep and PNP (disable and enable) with IO Before and After (Certification)
3.DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification)
package info:
virtio-win-1.6.7-2.el7.noarch
kernel-3.10.0-84.el7.x86_64
qemu-kvm-rhev-1.5.3-45.el7.x86_64
seabios-1.7.2.2-11.el7.x86_64
(In reply to Mike Cao from comment #7)
> lijin,pls help to check whether it can be reproduced without PM support
as comment #0 said,jobs can pass if S4 is disabled in qemu command
Created attachment 854873 [details] win8.1-64-netkvm-hck-file Description of problem: win8.1-64 and win2012R2 guest always hang when run the four hck jobs: DF - Sleep with IO During (Certification) DF - Sleep and PNP (disable and enable) with IO Before and After (Certification) DF - Concurrent Hardware And Operating System (CHAOS) Test (Certification) NDISTest 6.5 - [2 Machine] - MPE_Ethernet.xml Version-Release number of selected component (if applicable): qemu-kvm-rhev-1.5.3-30.el7.x86_64 kernel-3.10.0-64.el7.x86_64 seabios-1.7.2.2-7.el7.x86_64 virtio-win-prewhql-1.6.7-2 How reproducible: 100% Steps to Reproduce: 1.boot two guests with: nic1: /usr/libexec/qemu-kvm -m 6G -M pc -smp 8,cores=8 -cpu SandyBridge,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic -usb -device usb-tablet -drive file=win2012-R2-nic1.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -uuid 5044b1e3-9c86-438e-87c1-8aba752e7430 -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=a11,path=/tmp/monitor-win2k12R2-netkvm-1.6.7-2,server,nowait -mon chardev=a11,mode=readline -vnc :5 -vga cirrus -chardev socket,id=channel0,path=/tmp/tt,server,nowait -name win2k12R2-netkvm-1.6.7-2-nic1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -cdrom /usr/share/virtio-win/virtio-win.iso -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:23:a8:63:62:61,id=net0 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup1,downscript=no -device e1000,netdev=hostnet1,mac=00:23:a8:23:22:21,id=net1 nic2: /usr/libexec/qemu-kvm -m 2G -M pc -smp 2,cores=2 -cpu SandyBridge,hv_spinlocks=0x1fff,hv_relaxed,hv_vapic -usb -device usb-tablet -drive file=win2012-R2-nic2.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -uuid 3137012a-99ac-4355-a79b-f16fc2b3f3a3 -rtc-td-hack -no-kvm-pit-reinjection -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=a11,path=/tmp/monitor-win2k12R2-netkvm-1.6.7-2,server,nowait -mon chardev=a11,mode=readline -vnc :6 -vga cirrus -chardev socket,id=channel0,path=/tmp/tt,server,nowait -name win2k12R2-netkvm-1.6.7-2-nic2 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio -cdrom /usr/share/virtio-win/virtio-win.iso -netdev tap,sndbuf=0,id=hostnet0,vhost=on,script=/etc/qemu-ifup-private,downscript=no -device virtio-net-pci,netdev=hostnet0,mac=00:23:a8:64:75:86 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup1,downscript=no -device e1000,netdev=hostnet1,mac=00:23:a8:65:50:29 2.submit jobs in hck2.1 Actual results: guest hang while running the four jobs above,reboot guest and job failed Expected results: no hang,jobs can pass Additional info: 1.jobs can pass if S4 is disabled in qemu command; 2.NMICrashDump is enabled in guests,but cannot generate any dump file when set nmi in qemu monitor,guest has no response to nmi command.