Bug 1057811 - Failed to activate service 'org.freedesktop.login1': timed out
Summary: Failed to activate service 'org.freedesktop.login1': timed out
Keywords:
Status: CLOSED DUPLICATE of bug 1043212
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-25 00:22 UTC by Tom Horsley
Modified: 2014-02-23 16:01 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-23 16:01:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Tom Horsley 2014-01-25 00:22:22 UTC
Description of problem:

My log is being choked with these messages that apparently come out every four or five minutes (sometimes more often):

Jan 24 04:10:01 zooty dbus-daemon: dbus[25228]: [system] Activating systemd to hand-off: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Jan 24 04:10:01 zooty dbus[25228]: [system] Activating systemd to hand-off: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Jan 24 04:10:26 zooty dbus-daemon: dbus[25228]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Jan 24 04:11:59 zooty dbus-daemon: dbus[25228]: [system] Activating systemd to hand-off: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Jan 24 04:11:59 zooty dbus[25228]: [system] Activating systemd to hand-off: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Jan 24 04:12:24 zooty dbus[25228]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Jan 24 04:12:24 zooty dbus-daemon: dbus[25228]: [system] Failed to activate service 'org.freedesktop.login1': timed out
Jan 24 04:14:01 zooty dbus-daemon: dbus[25228]: [system] Activating systemd to hand-off: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Jan 24 04:14:01 zooty dbus[25228]: [system] Activating systemd to hand-off: service name='org.freedesktop.login1' unit='dbus-org.freedesktop.login1.service'
Jan 24 04:14:26 zooty dbus[25228]: [system] Failed to activate service 'org.freedesktop.login1': timed out
...

This apparently starts following the cron.daily run. On a cleanly booted system the errors do not happen, but around 4am when cron.daily runs, this just immediately starts filling the log and doesn't stop.


Version-Release number of selected component (if applicable):
systemd-208-9.fc20.x86_64

How reproducible:
every day

Steps to Reproduce:
1.install fedora 20
2.wait for cron.daily to run
3.

Actual results:
systemd goes funny in the head

Expected results:
system doesn't get all screwy just because cron ran.

Additional info:

I suspect these are all related:
https://bugzilla.redhat.com/show_bug.cgi?id=1057618
https://bugzilla.redhat.com/show_bug.cgi?id=1057614
https://bugzilla.redhat.com/show_bug.cgi?id=1043212

Comment 1 chen haochuan 2014-02-03 01:22:42 UTC
Maybe this is also related:
https://bugzilla.redhat.com/show_bug.cgi?id=1057982

Did you run "yum update" or use yum to install new packages before this happened?

Comment 2 Tom Horsley 2014-02-08 00:24:38 UTC
I'm almost completely convinced this is from the same fundamental cause as bug 1043212, just a different symptom cropping up.

Comment 3 Lennart Poettering 2014-02-23 16:01:50 UTC

*** This bug has been marked as a duplicate of bug 1043212 ***


Note You need to log in before you can comment on or make changes to this bug.